summaryrefslogtreecommitdiffstats
path: root/php73.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php73.spec')
-rw-r--r--php73.spec33
1 files changed, 23 insertions, 10 deletions
diff --git a/php73.spec b/php73.spec
index 795e811..dc63534 100644
--- a/php73.spec
+++ b/php73.spec
@@ -26,13 +26,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
%ifarch aarch64
-%global oraclever 19.19
+%global oraclever 19.23
+%global oraclemax 20
%global oraclelib 19.1
-%global oracledir 19.19
+%global oracledir 19.23
%else
-%global oraclever 21.13
-%global oraclelib 21.1
-%global oracledir 21
+%global oraclever 23.5
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
%endif
# Build for LiteSpeed Web Server (LSAPI)
@@ -122,7 +124,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 13%{?dist}
+Release: 15%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -209,6 +211,7 @@ Patch210: php-cve-2023-3823.patch
Patch211: php-cve-2023-3824.patch
Patch212: php-cve-2024-2756.patch
Patch213: php-cve-2024-3096.patch
+Patch214: php-cve-2024-5458.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -755,7 +758,7 @@ BuildRequires: oracle-instantclient%{oraclever}-devel
Requires: libclntsh.so.%{oraclelib}
AutoReq: 0
%else
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
%endif
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
@@ -1056,12 +1059,14 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
+%if 0%{?rhel}
# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
BuildRequires: libicu-devel = 69.1
-%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
Obsoletes: php73-intl, php73w-intl
+%else
+BuildRequires: libicu-devel
%endif
%description intl
@@ -1209,6 +1214,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch -P211 -p1 -b .cve3824
%patch -P212 -p1 -b .cve2756
%patch -P213 -p1 -b .cve3096
+%patch -P214 -p1 -b .cve5458
# Fixes for tests
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -2115,7 +2121,7 @@ cat << EOF
WARNING : PHP 7.3 have reached its "End of Life" in
December 2021. Even, if this package includes some of
- the important security fixes, backported from 8.0, the
+ the important security fixes, backported from 8.1, the
UPGRADE to a maintained version is very strongly RECOMMENDED.
=====================================================================
@@ -2303,8 +2309,15 @@ EOF
%changelog
+* Wed Jul 31 2024 Remi Collet <remi@remirepo.net> - 7.3.33-15
+- use oracle client library version 23.5 on x86_64
+
+* Tue Jun 4 2024 Remi Collet <remi@remirepo.net> - 7.3.33-14
+- Fix filter bypass in filter_var FILTER_VALIDATE_URL
+ CVE-2024-5458
+
* Wed Apr 10 2024 Remi Collet <remi@remirepo.net> - 7.3.33-13
-- use oracle client library version 21.11 on x86_64, 19.19 on aarch64
+- use oracle client library version 21.13 on x86_64, 19.19 on aarch64
- Fix __Host-/__Secure- cookie bypass due to partial CVE-2022-31629 fix
CVE-2024-2756
- Fix password_verify can erroneously return true opening ATO risk