summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-22 13:57:44 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-22 13:57:44 +0100
commit01f543c87c84f6334ed9bcb401356893a03fa832 (patch)
tree14d8490d70b5a48df4b07085939bb343df9e9f2b
parent65d859c12ace1313e130f0722c8cb3abd8c2a51a (diff)
php-punic: 1.6.4
-rw-r--r--composer.json48
-rwxr-xr-xphp-punic-get-source.sh4
-rw-r--r--php-punic.spec7
3 files changed, 56 insertions, 3 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..88c4b42
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,48 @@
+{
+ "name": "punic/punic",
+ "description": "PHP-Unicode CLDR",
+ "keywords": [
+ "localization",
+ "l10n",
+ "internationalization",
+ "i18n",
+ "translations",
+ "translate",
+ "php",
+ "unicode",
+ "cldr",
+ "calendar",
+ "date-time",
+ "date",
+ "time"
+ ],
+ "homepage": "https://github.com/punic/punic",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Michele Locati",
+ "email": "mlocati@gmail.com",
+ "role": "Developer"
+ },
+ {
+ "name": "Remo Laubacher",
+ "email": "remo.laubacher@gmail.com",
+ "role": "Collaborator, motivator and perfectionist supporter"
+ }
+ ],
+ "autoload": {
+ "psr-4": {
+ "Punic\\": "code/"
+ }
+ },
+ "require": {
+ "php": ">=5.3"
+ },
+ "require-dev": {
+ "apigen/apigen": "4.0.*"
+ },
+ "replace": {
+ "punic/common": "*",
+ "punic/calendar": "*"
+ }
+}
diff --git a/php-punic-get-source.sh b/php-punic-get-source.sh
index ba71f5d..9399d7f 100755
--- a/php-punic-get-source.sh
+++ b/php-punic-get-source.sh
@@ -43,6 +43,8 @@ print "GIT_REPO = $GIT_REPO"
print "GIT_DIR = $GIT_DIR"
TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
pushd $TEMP_DIR
print "Cloning git repo..."
@@ -51,6 +53,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
@@ -58,7 +61,6 @@ pushd $TEMP_DIR
mv $GIT_DIR $TAR_DIR
- TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
print "TAR_FILE = $TAR_FILE"
[ -e $TAR_FILE ] && rm -f $TAR_FILE
diff --git a/php-punic.spec b/php-punic.spec
index 645b5bf..3c1c1af 100644
--- a/php-punic.spec
+++ b/php-punic.spec
@@ -12,8 +12,8 @@
%global github_owner punic
%global github_name punic
-%global github_version 1.6.3
-%global github_commit 5805b35d6a574f754b49be1f539aaf3ae6484808
+%global github_version 1.6.4
+%global github_commit c6a779cb0349948f093d40b9f6a4fe5c6f8a6a36
%global composer_vendor punic
%global composer_project punic
@@ -166,6 +166,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Nov 22 2016 Remi Collet <remi@remirepo.net> - 1.6.4-1
+- update to 1.6.4
+
* Mon Sep 21 2015 Remi Collet <remi@remirepo.net> - 1.6.3-1
- backport for #remirepo