summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-19 07:30:23 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-19 07:30:23 +0100
commita2e7672a07fe3a871b1f6b4a973cda4b846abaf9 (patch)
tree345dc4dfbc4385b889d23201d3d044ce406316be /Makefile
parenta354f5bab30ff96ff5274a0159cc3f4e9572468d (diff)
php-pluf: backportHEADmaster
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed