summaryrefslogtreecommitdiffstats
path: root/php-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-mongodb.spec')
-rw-r--r--php-mongodb.spec33
1 files changed, 7 insertions, 26 deletions
diff --git a/php-mongodb.spec b/php-mongodb.spec
index df78b37..febcda0 100644
--- a/php-mongodb.spec
+++ b/php-mongodb.spec
@@ -6,6 +6,7 @@
#
# Please, preserve the changelog entries
#
+
# disabled for https://fedoraproject.org/wiki/Changes/MongoDB_Removal
%bcond_with tests
@@ -23,7 +24,7 @@
Name: php-%{gh_owner}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: MongoDB driver library
License: Apache-2.0
@@ -36,7 +37,7 @@ Source1: makesrc.sh
Patch0: %{name}-rpm.patch
BuildArch: noarch
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.1
BuildRequires: php-cli
BuildRequires: php-reflection
BuildRequires: php-date
@@ -44,17 +45,7 @@ BuildRequires: php-dom
BuildRequires: php-hash
BuildRequires: php-json
BuildRequires: php-spl
-# remirepo:1
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/log) >= 1.1.4 with php-composer(psr/log) < 4)
-BuildRequires: (php-composer(symfony/polyfill-php80) >= 1.27 with php-composer(symfony/polyfill-php80) < 2)
-BuildRequires: (php-composer(symfony/polyfill-php81) >= 1.27 with php-composer(symfony/polyfill-php81) < 2)
-# remirepo:5
-%else
-BuildRequires: php-PsrLog >= 1.1.4
-BuildRequires: php-symfony-polyfill < 2
-BuildRequires: php-symfony-polyfill >= 1.27
-%endif
%if %{with tests}
BuildRequires: mongodb-server >= 2.4
BuildRequires: php-pecl(mongodb) >= %{ext_version}
@@ -80,21 +71,11 @@ BuildRequires: php-composer(fedora/autoloader)
# "psr/log": "^1.1.4|^2|^3",
# "symfony/polyfill-php80": "^1.27",
# "symfony/polyfill-php81": "^1.27"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.1
Requires: php-hash
Requires: php-json
Requires: php-pecl(mongodb) >= %{ext_version}
-# remirepo:1
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
Requires: (php-composer(psr/log) >= 1.1.4 with php-composer(psr/log) < 4)
-Requires: (php-composer(symfony/polyfill-php80) >= 1.27 with php-composer(symfony/polyfill-php80) < 2)
-Requires: (php-composer(symfony/polyfill-php81) >= 1.27 with php-composer(symfony/polyfill-php81) < 2)
-# remirepo:5
-%else
-Requires: php-PsrLog >= 1.1.4
-Requires: php-symfony-polyfill < 2
-Requires: php-symfony-polyfill >= 1.27
-%endif
# From phpcompatinfo report for 1.8.0
Requires: php-reflection
Requires: php-date
@@ -135,7 +116,6 @@ require_once __DIR__. '/functions.php';
'%{_datadir}/php/Psr/Log2/autoload.php',
'%{_datadir}/php/Psr/Log/autoload.php',
],
- '%{_datadir}/php/Symfony/Polyfill/autoload.php',
]);
EOF
@@ -207,8 +187,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc *.md
@@ -217,6 +195,9 @@ exit $ret
%changelog
+* Mon Sep 9 2024 Remi Collet <remi@remirepo.net> - 1.19.1-3
+- drop dependency on symfony/polyfill
+
* Fri Jun 14 2024 Remi Collet <remi@remirepo.net> - 1.19.1-1
- update to 1.19.1 (no change)