summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-03-13 14:19:42 +0100
committerRemi Collet <remi@php.net>2025-03-13 14:19:42 +0100
commit0a2095dc522a4b6a2578d656360487707e881765 (patch)
treefa553aa7f39be148e14cb2ce7c5a4a4e5e2b1745
parent7de6cc3503441354fe3e0f12e7944fcff2adce79 (diff)
update to 3.72.0HEADmaster
-rw-r--r--composer.json12
-rw-r--r--php-cs-fixer-autoload.patch2
-rw-r--r--php-cs-fixer.spec13
3 files changed, 16 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index cf6fd66..2d2ab75 100644
--- a/composer.json
+++ b/composer.json
@@ -46,18 +46,18 @@
"symfony/stopwatch": "^5.4 || ^6.4 || ^7.0"
},
"require-dev": {
- "facile-it/paraunit": "^1.3.1 || ^2.5",
- "infection/infection": "^0.29.10",
- "justinrainbow/json-schema": "^5.3 || ^6.0",
+ "facile-it/paraunit": "^1.3.1 || ^2.6",
+ "infection/infection": "^0.29.14",
+ "justinrainbow/json-schema": "^5.3 || ^6.2",
"keradus/cli-executor": "^2.1",
"mikey179/vfsstream": "^1.6.12",
"php-coveralls/php-coveralls": "^2.7",
"php-cs-fixer/accessible-object": "^1.1",
"php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.6",
"php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.6",
- "phpunit/phpunit": "^9.6.22 || ^10.5.45 || ^11.5.7",
- "symfony/var-dumper": "^5.4.48 || ^6.4.18 || ^7.2.0",
- "symfony/yaml": "^5.4.45 || ^6.4.18 || ^7.2.0"
+ "phpunit/phpunit": "^9.6.22 || ^10.5.45 || ^11.5.12",
+ "symfony/var-dumper": "^5.4.48 || ^6.4.18 || ^7.2.3",
+ "symfony/yaml": "^5.4.45 || ^6.4.18 || ^7.2.3"
},
"suggest": {
"ext-dom": "For handling output formats in XML",
diff --git a/php-cs-fixer-autoload.patch b/php-cs-fixer-autoload.patch
index 983d89a..a14e08a 100644
--- a/php-cs-fixer-autoload.patch
+++ b/php-cs-fixer-autoload.patch
@@ -1,7 +1,7 @@
diff -up ./php-cs-fixer.rpm ./php-cs-fixer
--- ./php-cs-fixer.rpm 2022-01-14 15:01:36.281743286 +0100
+++ ./php-cs-fixer 2022-01-14 15:01:59.983646138 +0100
-@@ -85,7 +85,7 @@ set_error_handler(static function ($seve
+@@ -81,7 +81,7 @@ set_error_handler(static function ($seve
if ($require) {
// OK, it's not, let give Composer autoloader a try!
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 7e63c8e..7fa7f38 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -11,14 +11,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 3825ffdc69501e1c9230291b79f036a0c0d8749d
+%global gh_commit 900389362c43d116fee1ffc51f7878145fa61b57
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2025-03-07
+%global gh_date 2025-03-13
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.71.0
+Version: 3.72.0
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -71,7 +71,9 @@ projects. This tool does not only detect them, but also fixes them for you.
%patch -P0 -p1 -b .rpm
# Fix version
-sed -e '/VERSION/s/3.68.6-DEV/%{version}/' -i src/Console/Application.php
+#sed -e '/VERSION/s/3.68.6-DEV/%{version}/' -i src/Console/Application.php
+# check version
+grep "'%{version}'" src/Console/Application.php
%build
@@ -104,6 +106,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Thu Mar 13 2025 Remi Collet <remi@remirepo.net> - 3.72.0-1
+- update to 3.72.0
+
* Sat Mar 8 2025 Remi Collet <remi@remirepo.net> - 3.71.0-1
- update to 3.71.0