summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-zip.spec5
-rw-r--r--zip-php84.patch26
2 files changed, 30 insertions, 1 deletions
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index b207396..04dc9fd 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -42,7 +42,7 @@
Summary: A ZIP archive management extension
Name: %{?scl_prefix}php-pecl-zip
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
Group: Development/Languages
URL: https://pecl.php.net/package/zip
@@ -221,6 +221,9 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
%changelog
+* Wed Aug 21 2024 Remi Collet <remi@remirepo.net> - 1.22.3-4
+- fix previous patch (for 8.0)
+
* Wed Jul 17 2024 Remi Collet <remi@remirepo.net> - 1.22.3-3
- rebuild for 8.4.0alpha2
diff --git a/zip-php84.patch b/zip-php84.patch
index e50b9e0..90127ce 100644
--- a/zip-php84.patch
+++ b/zip-php84.patch
@@ -184,3 +184,29 @@ index 274ddf1..97194ba 100644
"zip",
ext_functions,
PHP_MINIT(zip),
+From 6734db54ab2c9176e58ae456b794657374688fba Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 21 Aug 2024 14:43:10 +0200
+Subject: [PATCH] fix init
+
+---
+ php8/php_zip.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/php8/php_zip.c b/php8/php_zip.c
+index 93d633b..9b388a6 100644
+--- a/php8/php_zip.c
++++ b/php8/php_zip.c
+@@ -1149,8 +1149,8 @@ static const zend_module_dep zip_deps[] = {
+ /* {{{ zip_module_entry */
+ zend_module_entry zip_module_entry = {
+ STANDARD_MODULE_HEADER_EX, NULL,
+- "zip",
+ zip_deps,
++ "zip",
+ ext_functions,
+ PHP_MINIT(zip),
+ PHP_MSHUTDOWN(zip),
+--
+2.46.0
+