summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION42
-rw-r--r--php-pecl-xpass.spec7
3 files changed, 46 insertions, 5 deletions
diff --git a/PHPINFO b/PHPINFO
index e3b18d4..f581342 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xpass
Extended password support => enabled
-Extension version => 1.0.0
+Extension version => 1.1.0RC1
libxcrypt version => 4.4.36
Author => Remi Collet
License => PHP-3.01
diff --git a/REFLECTION b/REFLECTION
index 9c6efc5..6d2bf4d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,8 +1,46 @@
-Extension [ <persistent> extension #102 xpass version 1.0.0 ] {
+Extension [ <persistent> extension #102 xpass version 1.1.0RC1 ] {
- - Constants [2] {
+ - Constants [16] {
+ Constant [ string CRYPT_PREFIX_STD_DES ] { }
+ Constant [ string CRYPT_PREFIX_EXT_DES ] { _ }
+ Constant [ string CRYPT_PREFIX_MD5 ] { $1$ }
+ Constant [ string CRYPT_PREFIX_BLOWFISH ] { $2y$ }
+ Constant [ string CRYPT_PREFIX_SHA256 ] { $5$ }
+ Constant [ string CRYPT_PREFIX_SHA512 ] { $6$ }
+ Constant [ string CRYPT_PREFIX_SCRYPT ] { $7$ }
+ Constant [ string CRYPT_PREFIX_GOST_YESCRYPT ] { $gy$ }
+ Constant [ string CRYPT_PREFIX_YESCRYPT ] { $y$ }
+ Constant [ int CRYPT_SALT_OK ] { 0 }
+ Constant [ int CRYPT_SALT_INVALID ] { 1 }
+ Constant [ int CRYPT_SALT_METHOD_DISABLED ] { 2 }
+ Constant [ int CRYPT_SALT_METHOD_LEGACY ] { 3 }
+ Constant [ int CRYPT_SALT_TOO_CHEAP ] { 4 }
Constant [ string PASSWORD_SHA512 ] { 6 }
Constant [ string PASSWORD_YESCRYPT ] { y }
}
+
+ - Functions {
+ Function [ <internal:xpass> function crypt_gensalt ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> ?string $prefix = null ]
+ Parameter #1 [ <optional> int $count = 0 ]
+ }
+ - Return [ ?string ]
+ }
+ Function [ <internal:xpass> function crypt_preferred_method ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?string ]
+ }
+ Function [ <internal:xpass> function crypt_checksalt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $salt ]
+ }
+ - Return [ int ]
+ }
+ }
}
diff --git a/php-pecl-xpass.spec b/php-pecl-xpass.spec
index e1f9c94..6506ca4 100644
--- a/php-pecl-xpass.spec
+++ b/php-pecl-xpass.spec
@@ -14,8 +14,8 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name xpass
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.0.0
-#global upstream_prever RC2
+%global upstream_version 1.1.0
+%global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -172,6 +172,9 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Fri Sep 13 2024 Remi Collet <remi@remirepo.net> - 1.1.0~RC1-1
+- update to 1.1.0RC1
+
* Mon Sep 9 2024 Remi Collet <remi@remirepo.net> - 1.0.0-1
- update to 1.0.0