summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-08-28 16:32:39 +0200
committerRemi Collet <remi@php.net>2024-08-28 16:32:39 +0200
commit030c02ab38f20501ed5fd6951d0b3cae0f008e04 (patch)
tree41c258e1c004c9fc3c95befb0dea8d1545848c74
initial package, version 1.0.0RC1
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-xpass.spec176
5 files changed, 207 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..594fe81
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,10 @@
+
+xpass
+
+Extended password support => enabled
+Extension version => 1.0.0RC1
+libxcrypt version => 4.4.36
+Author => Remi Collet
+License => PHP-3.01
+sha512 hash => yes
+yescrypt hash => yes
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..6071055
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,8 @@
+Extension [ <persistent> extension #101 xpass version 1.0.0RC1 ] {
+
+ - Constants [2] {
+ Constant [ string PASSWORD_SHA512 ] { 6 }
+ Constant [ string PASSWORD_YESCRYPT ] { y }
+ }
+}
+
diff --git a/php-pecl-xpass.spec b/php-pecl-xpass.spec
new file mode 100644
index 0000000..9d5e342
--- /dev/null
+++ b/php-pecl-xpass.spec
@@ -0,0 +1,176 @@
+# remirepo spec file for php-pecl-xpass
+#
+# Copyright (c) 2024 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+%{?scl:%scl_package php-pecl-xpass}
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name xpass
+%global ini_name 40-%{pecl_name}.ini
+%global upstream_version 1.0.0
+%global upstream_prever RC1
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
+
+Summary: RPM information
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP-3.01
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: pkgconfig(libxcrypt) >= 4.4
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+
+%description
+This extension provides password hashing algorithms used by Linux
+distributions, using extended crypt library (libxcrypt):
+
+* sha512 provided for legacy as used on some old distributions
+* yescrypt used on modern distributions
+
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
+ -i package.xml
+
+cd %{sources}
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_XPASS_VERSION/{s/.* "//;s/".*$//;p}' php_xpass.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+mkdir NTS
+%if %{with_zts}
+mkdir ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+%configure \
+ --enable-xpass \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%configure \
+ --enable-xpass \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__ztsphpconfig}
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS \
+ install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS \
+ install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd %{sources}
+# Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with tests}
+# Upstream test suite for NTS extension
+TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+%endif
+
+%if %{with_zts}
+# Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with tests}
+# Upstream test suite for ZTS extension
+TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
+%{__ztsphp} -n run-tests.php -q --show-diff %{?_smp_mflags}
+%endif
+%endif
+
+
+%files
+%license %{sources}/LICENSE
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 1.0.0~RC1-1
+- initial package, version 1.0.0RC1