summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xlswriter.spec52
3 files changed, 17 insertions, 39 deletions
diff --git a/PHPINFO b/PHPINFO
index 9826b3e..e912be8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
xlswriter
xlswriter support => enabled
-Version => 1.5.5
+Version => 1.5.7
bundled libxlsxwriter version => 1.1.3
bundled libxlsxio version => 0.2.27
diff --git a/REFLECTION b/REFLECTION
index c3d3e93..77028e3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #103 xlswriter version 1.5.5 ] {
+Extension [ <persistent> extension #101 xlswriter version 1.5.7 ] {
- Functions {
Function [ <internal:xlswriter> function xlswriter_get_version ] {
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 4ad7998..d8afba8 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -1,30 +1,22 @@
# remirepo spec file for php-pecl-xlswriter
#
-# Copyright (c) 2018-2023 Remi Collet
+# Copyright (c) 2018-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
%bcond_with syslib
%bcond_without tests
%{?scl:%scl_package php-pecl-xlswriter}
-# Defined in Fedora >= 37 and RHEL >= 10, in PHP >= 7.4 for remirepo
-%{!?__phpize: %global __phpize %{_bindir}/phpize}
-%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
-%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
-%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
-
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name xlswriter
%global ini_name 40-%{pecl_name}.ini
%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
%if %{with syslib}
# No soname, so manage dependency on available version
@@ -34,7 +26,7 @@
Summary: An efficient and fast xlsx file extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.5.5
+Version: 1.5.7
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
@@ -52,7 +44,6 @@ BuildRequires: zlib-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
%if %{with syslib}
Requires: libxlsxwriter%{?_isa} >= %{libxlsxwriter_version}
Requires: libxlsxio%{?_isa} >= %{libxlsxio_version}
@@ -103,7 +94,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -q -c
# Don't install tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-e '/name="library/d' \
-i package.xml
@@ -134,8 +125,6 @@ extension=%{pecl_name}.so
EOF
-%global _configure ../%{sources}/configure
-
%build
%{?dtsenable}
@@ -188,26 +177,6 @@ do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
OPT="-q -P --show-diff"
%if "%{php_version}" > "7.4"
@@ -237,14 +206,14 @@ REPORT_EXIT_STATUS=1 \
: Upstream test suite for ZTS extension
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/zts-php -n run-tests.php $OPT
+%{__ztsphp} -n run-tests.php $OPT
%endif
%endif
cd ..
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -258,6 +227,15 @@ cd ..
%changelog
+* Wed Sep 4 2024 Remi Collet <remi@remirepo.net> - 1.5.7-1
+- update to 1.5.7
+
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 1.5.6-1
+- update to 1.5.6
+
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.5.5-2
+- rebuild for PHP 8.3.0RC1
+
* Tue May 16 2023 Remi Collet <remi@remirepo.net> - 1.5.5-1
- update to 1.5.5
- build out of sources tree