summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xdebug3.spec38
3 files changed, 12 insertions, 30 deletions
diff --git a/PHPINFO b/PHPINFO
index 79c9824..501c002 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -10,7 +10,7 @@ xdebug
 __/ |
 |___/
-Version => 3.4.0beta1
+Version => 3.4.0
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Enabled Features (through 'xdebug.mode' setting)
diff --git a/REFLECTION b/REFLECTION
index 5fb2417..3a7f90d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #17 xdebug version 3.4.0beta1 ] {
+Extension [ <persistent> extension #17 xdebug version 3.4.0 ] {
- INI {
Entry [ xdebug.mode <SYSTEM> ]
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index b935e78..6dd3d2f 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -19,13 +19,12 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 921255659710b07db816bc0c71941a5a00b6bf6c
+%global gh_commit 4284879cc0e3d749f872c2b7eec49521ca4b9ad0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20201011
# version/release
%global upstream_version 3.4.0
-%global upstream_prever beta1
+#global upstream_prever beta1
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources src
%global _configure ../%{sources}/configure
@@ -35,18 +34,12 @@
Name: %{?scl_prefix}php-pecl-xdebug3
Summary: Provides functions for function traces and profiling
-Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
-%if 0%{?gh_date:1}
-Release: 1.%{gh_date}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
License: Xdebug-1.03
URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
-# file is corrupted in 3.4.0beta1 tag
-Source1: https://raw.githubusercontent.com/%{pecl_name}/%{pecl_name}/refs/tags/3.4.0alpha1/xdebug.ini
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -98,32 +91,18 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
mv %{pecl_name}-%{gh_commit} %{sources}
-
-%if 0%{?gh_date:1}
-%{__php} -r '
- $pkg = simplexml_load_file("NTS/package.xml");
- $pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
- $pkg->version->release = "%{upstream_version}dev";
- $pkg->stability->release = "devel";
- $pkg->asXML("package.xml");
-'
-%else
mv %{sources}/package.xml .
-%endif
sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
-cd %{sources}
-cp %{SOURCE1} xdebug.ini
-
+pushd %{sources}
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
-if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
- : Error: Upstream XDEBUG_VERSION version is ${ver}, expecting %{upstream_version}%{?upstream_perver}%{?gh_date:-dev}.
+if test "$ver" != "%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream XDEBUG_VERSION version is ${ver}, expecting %{upstream_version}%{?upstream_perver}
exit 1
fi
-
-cd ..
+popd
mkdir NTS
%if %{with_zts}
@@ -279,6 +258,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Nov 28 2024 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+
* Fri Oct 4 2024 Remi Collet <remi@remirepo.net> - 3.4.0~beta1-1
- update to 3.4.0beta1