summaryrefslogtreecommitdiffstats
path: root/php-pecl-vld.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-vld.spec')
-rw-r--r--php-pecl-vld.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-pecl-vld.spec b/php-pecl-vld.spec
index 13fe7bb..c46fae0 100644
--- a/php-pecl-vld.spec
+++ b/php-pecl-vld.spec
@@ -23,7 +23,7 @@ Summary: Dump the internal representation of PHP scripts
Name: %{?scl_prefix}php-pecl-%{pecl_name}
License: PHP-3.01
Version: 0.18.0
-Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 6%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
@@ -96,24 +96,26 @@ EOF
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -122,7 +124,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -163,6 +165,9 @@ done
%changelog
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 0.18.0-6
+- rebuild for 8.4.0RC1
+
* Thu Aug 29 2024 Remi Collet <remi@remirepo.net> - 0.18.0-5
- add upstream patch for PHP 8.4.0beta4