summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION44
-rw-r--r--php-pecl-uuid.spec21
-rw-r--r--uuid-workaround.patch42
4 files changed, 36 insertions, 75 deletions
diff --git a/PHPINFO b/PHPINFO
index fa74e96..2313fee 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
uuid
UUID extension => enabled
-Version => 1.2.0 (stable)
-Released => 2020-10-06
+Version => 1.2.1 (stable)
+Released => 2024-10-08
Authors => Hartmut Holzgraefe, Remi Collet
diff --git a/REFLECTION b/REFLECTION
index d6a04df..36bf9c0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #102 uuid version 1.2.0 ] {
+Extension [ <persistent> extension #102 uuid version 1.2.1 ] {
- Constants [14] {
Constant [ int UUID_VARIANT_NCS ] { 0 }
@@ -21,77 +21,89 @@ Extension [ <persistent> extension #102 uuid version 1.2.0 ] {
Function [ <internal:uuid> function uuid_create ] {
- Parameters [1] {
- Parameter #0 [ <optional> $uuid_type ]
+ Parameter #0 [ <optional> int $uuid_type = UUID_TYPE_DEFAULT ]
}
+ - Return [ string ]
}
Function [ <internal:uuid> function uuid_is_valid ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ bool ]
}
Function [ <internal:uuid> function uuid_compare ] {
- Parameters [2] {
- Parameter #0 [ <required> $uuid1 ]
- Parameter #1 [ <required> $uuid2 ]
+ Parameter #0 [ <required> string $uuid1 ]
+ Parameter #1 [ <required> string $uuid2 ]
}
+ - Return [ int ]
}
Function [ <internal:uuid> function uuid_is_null ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ bool ]
}
Function [ <internal:uuid> function uuid_generate_md5 ] {
- Parameters [2] {
- Parameter #0 [ <required> $uuid_ns ]
- Parameter #1 [ <required> $name ]
+ Parameter #0 [ <required> string $uuid_ns ]
+ Parameter #1 [ <required> string $name ]
}
+ - Return [ string ]
}
Function [ <internal:uuid> function uuid_generate_sha1 ] {
- Parameters [2] {
- Parameter #0 [ <required> $uuid_ns ]
- Parameter #1 [ <required> $name ]
+ Parameter #0 [ <required> string $uuid_ns ]
+ Parameter #1 [ <required> string $name ]
}
+ - Return [ string ]
}
Function [ <internal:uuid> function uuid_type ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ int ]
}
Function [ <internal:uuid> function uuid_variant ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ int ]
}
Function [ <internal:uuid> function uuid_time ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ int ]
}
Function [ <internal:uuid> function uuid_mac ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ string ]
}
Function [ <internal:uuid> function uuid_parse ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ string ]
}
Function [ <internal:uuid> function uuid_unparse ] {
- Parameters [1] {
- Parameter #0 [ <required> $uuid ]
+ Parameter #0 [ <required> string $uuid ]
}
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index 8151d1c..be88ac3 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -23,14 +23,12 @@
Summary: Universally Unique Identifier extension for PHP
Name: %{?scl_prefix}php-pecl-uuid
-Version: 1.2.0
-Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: LGPL-2.1-or-later
URL: https://pecl.php.net/package/uuid
Source: https://pecl.php.net/get/%{sources}.tgz
-Patch0: %{pecl_name}-workaround.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -52,7 +50,7 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
%description
-A wrapper around Universally Unique Identifier library (libuuid).
+A wrapper around Universally Unique IDentifier library (libuuid).
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -66,8 +64,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1 -b .orig
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_UUID_VERSION/{s/.* "//;s/".*$//;p}' php_uuid.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -158,14 +154,6 @@ REPORT_EXIT_STATUS=1 \
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
-
-%if %{with tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --show-diff
-%endif
%endif
@@ -184,6 +172,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Oct 8 2024 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1
+
* Mon Sep 30 2024 Remi Collet <remi@remirepo.net> - 1.2.0-10
- fix workaround for recent util-linux
see https://bugzilla.redhat.com/2315645
diff --git a/uuid-workaround.patch b/uuid-workaround.patch
deleted file mode 100644
index a41e21a..0000000
--- a/uuid-workaround.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -up uuid-1.2.0/config.m4.orig uuid-1.2.0/config.m4
---- uuid-1.2.0/config.m4.orig 2020-10-06 12:50:46.000000000 +0200
-+++ uuid-1.2.0/config.m4 2024-09-30 13:55:26.600108993 +0200
-@@ -18,6 +18,7 @@ if test "$PHP_UUID" != "no"; then
- PHP_CHECK_FUNC_LIB(uuid_variant, uuid)
- PHP_CHECK_FUNC_LIB(uuid_generate_md5, uuid)
- PHP_CHECK_FUNC_LIB(uuid_generate_sha1, uuid)
-+ PHP_CHECK_FUNC_LIB(uuid_time64, uuid)
-
- export OLD_CPPFLAGS="$CPPFLAGS"
- export CPPFLAGS="$CPPFLAGS $INCLUDES -DHAVE_UUID"
-diff -up uuid-1.2.0/uuid.c.orig uuid-1.2.0/uuid.c
---- uuid-1.2.0/uuid.c.orig 2020-10-06 12:50:46.000000000 +0200
-+++ uuid-1.2.0/uuid.c 2024-09-30 13:56:33.329669413 +0200
-@@ -27,6 +27,15 @@
-
- #ifdef HAVE_UUID
-
-+#if defined(uuid_time)
-+/* workround with define uuid_time uuid_time64 */
-+/* Also see https://bugzilla.redhat.com/2315645 */
-+#undef uuid_time
-+#if !defined(HAVE_UUID_TIME64)
-+extern time_t uuid_time(const uuid_t uu, struct timeval *ret_tv);
-+#endif
-+#endif
-+
- #if PHP_VERSION_ID < 80000
- #define VALUE_ERROR(n,name,msg) php_error_docref(NULL, E_WARNING, "Argument #%d (%s) %s", n, name, msg); RETURN_FALSE
- #define RETURN_THROWS() return
-@@ -374,7 +383,11 @@ PHP_FUNCTION(uuid_time)
- VALUE_ERROR(1, "$uuid", "UUID DCE TIME expected");
- }
-
-+#if defined(HAVE_UUID_TIME64)
-+ RETURN_LONG(uuid_time64(u, NULL));
-+#else
- RETURN_LONG(uuid_time(u, NULL));
-+#endif
- }
- /* }}} uuid_time */
-