summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION80
-rw-r--r--php-pecl-teds.spec5
3 files changed, 69 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 5a20b34..52fabcb 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.3.0
+teds version => 0.4.1
diff --git a/REFLECTION b/REFLECTION
index 865bbf5..5f56463 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #82 teds version 0.3.0 ] {
+Extension [ <persistent> extension #82 teds version 0.4.1 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -75,7 +75,7 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Properties [0] {
}
- - Methods [21] {
+ - Methods [24] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -97,11 +97,11 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Return [ int ]
}
- Method [ <internal:teds> public method capacity ] {
+ Method [ <internal:teds> public method isEmpty ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Return [ bool ]
}
Method [ <internal:teds> public method clear ] {
@@ -126,30 +126,44 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Return [ void ]
}
- Method [ <internal:teds> public method pushBack ] {
+ Method [ <internal:teds> public method push ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $value ]
+ Parameter #0 [ <optional> mixed ...$values ]
}
- Return [ void ]
}
- Method [ <internal:teds> public method pushFront ] {
+ Method [ <internal:teds> public method unshift ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $value ]
+ Parameter #0 [ <optional> mixed ...$values ]
}
- Return [ void ]
}
- Method [ <internal:teds> public method popBack ] {
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method shift ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method bottom ] {
- Parameters [0] {
}
- Return [ mixed ]
}
- Method [ <internal:teds> public method popFront ] {
+ Method [ <internal:teds> public method top ] {
- Parameters [0] {
}
@@ -235,6 +249,13 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
}
- Return [ array ]
}
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
}
}
@@ -267,7 +288,7 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [16] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -289,6 +310,13 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Return [ int ]
}
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method toPairs ] {
- Parameters [0] {
@@ -403,7 +431,7 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Properties [0] {
}
- - Methods [14] {
+ - Methods [15] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -425,6 +453,13 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Return [ int ]
}
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method __serialize ] {
- Parameters [0] {
@@ -542,7 +577,7 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Properties [0] {
}
- - Methods [23] {
+ - Methods [24] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -564,6 +599,13 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Return [ int ]
}
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method capacity ] {
- Parameters [0] {
@@ -741,12 +783,11 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [25] {
Method [ <internal:teds, ctor> public method __construct ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <optional> iterable $iterator = [] ]
- Parameter #1 [ <optional> bool $preserveKeys = true ]
}
}
@@ -764,6 +805,13 @@ Extension [ <persistent> extension #82 teds version 0.3.0 ] {
- Return [ int ]
}
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds> public method capacity ] {
- Parameters [0] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 37765f1..48ef1bc 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.3.0
+%global upstream_version 0.4.1
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -195,6 +195,9 @@ fi
%changelog
+* Mon Sep 27 2021 Remi Collet <remi@remirepo.net> - 0.4.1-1
+- update to 0.4.1
+
* Mon Sep 20 2021 Remi Collet <remi@remirepo.net> - 0.3.0-1
- update to 0.3.0