summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole6.spec')
-rw-r--r--php-pecl-swoole6.spec33
1 files changed, 25 insertions, 8 deletions
diff --git a/php-pecl-swoole6.spec b/php-pecl-swoole6.spec
index c7195ac..ecb7155 100644
--- a/php-pecl-swoole6.spec
+++ b/php-pecl-swoole6.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-swoole6
#
-# Copyright (c) 2013-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2013-2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -42,11 +42,12 @@
%bcond_without pgsql
%bcond_without brotli
+%bcond_without zstd
%bcond_without curl
%bcond_without nghttpd2
%global upstream_version 6.0.0
-%global upstream_prever RC1
+#global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -55,7 +56,7 @@ Name: %{?scl_prefix}php-pecl-%{pecl_name}6
# Without prever, See https://github.com/swoole/swoole-src/issues/5531
#Version: %%{upstream_version}%%{?upstream_prever:~%%{upstream_prever}}
Version: %{upstream_version}
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is Apache-2.0
# BSD-3-Clause: Hiredis
# MIT: nlohmann/json, nghttp2
@@ -63,7 +64,7 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: 5579.patch
+Patch0: 0001-fix-cpu-affinity-check.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -87,6 +88,9 @@ BuildRequires: pkgconfig(libcares)
BuildRequires: pkgconfig(libbrotlidec)
BuildRequires: pkgconfig(libbrotlienc)
%endif
+%if %{with zstd}
+BuildRequires: pkgconfig(libzstd) >= 1.4
+%endif
%if %{with pgsql}
BuildRequires: pkgconfig(libpq)
%endif
@@ -123,7 +127,7 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if 0%{?fedora} >= 41 || 0%{?rhel} >= 10 || "%{php_version}" >= "8.4"
+%if 0%{?fedora} >= 42 || 0%{?rhel} >= 10 || "%{php_version}" >= "8.4"
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 6
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
@@ -199,7 +203,7 @@ rm -r thirdparty/nghttp2
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
%endif
-%patch -P0 -p1 -b .pr5579
+%patch -P0 -p1 -b .affinity
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
@@ -256,6 +260,11 @@ peclbuild() {
%else
--disable-brotli \
%endif
+%if %{with zstd}
+ --enable-zstd \
+%else
+ --disable-zstd \
+%endif
%if %{with nghttpd2}
--with-nghttp2-dir=%{_root_prefix} \
%endif
@@ -369,6 +378,14 @@ cd ../ZTS
%changelog
+* Mon Dec 16 2024 Remi Collet <remi@remirepo.net> - 6.0.0-5
+- update to 6.0.0 GA
+- enable zstd support
+- re-license spec file to CECILL-2.1
+- drop patch merged upstream
+- fix cpu affinity check using patch from
+ https://github.com/swoole/swoole-src/pull/5624
+
* Thu Nov 21 2024 Remi Collet <remi@remirepo.net> - 6.0.0-4
- update to 6.0.0RC1
- use 6.0.0-4 to workaround https://github.com/swoole/swoole-src/issues/5531