summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole6.spec')
-rw-r--r--php-pecl-swoole6.spec58
1 files changed, 40 insertions, 18 deletions
diff --git a/php-pecl-swoole6.spec b/php-pecl-swoole6.spec
index c7195ac..448d643 100644
--- a/php-pecl-swoole6.spec
+++ b/php-pecl-swoole6.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-swoole6
#
-# Copyright (c) 2013-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2013-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -14,6 +14,8 @@
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pie_vend swoole
+%global pie_proj swoole
%global pecl_name swoole
# After 20-sockets, 20-json and 20-mysqlnd
%global ini_name 40-%{pecl_name}.ini
@@ -42,20 +44,19 @@
%bcond_without pgsql
%bcond_without brotli
+%bcond_without zstd
%bcond_without curl
%bcond_without nghttpd2
-%global upstream_version 6.0.0
-%global upstream_prever RC1
+%global upstream_version 6.0.1
+#global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}6
-# Without prever, See https://github.com/swoole/swoole-src/issues/5531
-#Version: %%{upstream_version}%%{?upstream_prever:~%%{upstream_prever}}
-Version: %{upstream_version}
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is Apache-2.0
# BSD-3-Clause: Hiredis
# MIT: nlohmann/json, nghttp2
@@ -63,8 +64,6 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: 5579.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -87,6 +86,9 @@ BuildRequires: pkgconfig(libcares)
BuildRequires: pkgconfig(libbrotlidec)
BuildRequires: pkgconfig(libbrotlienc)
%endif
+%if %{with zstd}
+BuildRequires: pkgconfig(libzstd) >= 1.4
+%endif
%if %{with pgsql}
BuildRequires: pkgconfig(libpq)
%endif
@@ -118,12 +120,12 @@ Requires: %{?scl_prefix}php-sockets%{?_isa}
Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
Requires: %{?scl_prefix}php-pdo%{?_isa}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pie(%{pie_vend}/%{pie_proj}) = %{version}
-%if 0%{?fedora} >= 41 || 0%{?rhel} >= 10 || "%{php_version}" >= "8.4"
+%if 0%{?fedora} >= 42 || 0%{?rhel} >= 10 || "%{php_version}" >= "8.4"
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 6
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
@@ -146,6 +148,7 @@ Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}5 < 6
# Only one extension can be installed (same symbols)
Conflicts: %{?scl_prefix}php-pecl-openswoole
Conflicts: %{?scl_prefix}php-pecl-openswoole22
+Conflicts: %{?scl_prefix}php-pecl-openswoole25
%description
@@ -199,8 +202,6 @@ rm -r thirdparty/nghttp2
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
%endif
-%patch -P0 -p1 -b .pr5579
-
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -256,6 +257,11 @@ peclbuild() {
%else
--disable-brotli \
%endif
+%if %{with zstd}
+ --enable-zstd \
+%else
+ --disable-zstd \
+%endif
%if %{with nghttpd2}
--with-nghttp2-dir=%{_root_prefix} \
%endif
@@ -270,6 +276,9 @@ peclbuild() {
--with-libdir=%{_lib} \
--with-php-config=$*
+# See https://bugzilla.redhat.com/show_bug.cgi?id=2345743
+sed -e 's:-Wl,-rpath,/usr/usr/lib64 -L/usr/usr/lib64::' -i Makefile
+
%make_build
}
@@ -369,6 +378,19 @@ cd ../ZTS
%changelog
+* Fri Feb 14 2025 Remi Collet <remi@remirepo.net> - 6.0.1-1
+- update to 6.0.1
+- drop patch merged upstream
+- provide php-pie(swoole/swoole)
+
+* Mon Dec 16 2024 Remi Collet <remi@remirepo.net> - 6.0.0-5
+- update to 6.0.0 GA
+- enable zstd support
+- re-license spec file to CECILL-2.1
+- drop patch merged upstream
+- fix cpu affinity check using patch from
+ https://github.com/swoole/swoole-src/pull/5624
+
* Thu Nov 21 2024 Remi Collet <remi@remirepo.net> - 6.0.0-4
- update to 6.0.0RC1
- use 6.0.0-4 to workaround https://github.com/swoole/swoole-src/issues/5531