summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-missing-header.patch24
-rw-r--r--0002-fix-implicit-int.patch27
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-swoole5.spec47
5 files changed, 11 insertions, 99 deletions
diff --git a/0001-missing-header.patch b/0001-missing-header.patch
deleted file mode 100644
index 58784aa..0000000
--- a/0001-missing-header.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 10feb6a1ca1c396d323f4bf92acd67feae758a62 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 6 Jun 2024 10:08:05 +0200
-Subject: [PATCH] missing header
-
----
- thirdparty/php83/pdo_odbc/odbc_driver.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/thirdparty/php83/pdo_odbc/odbc_driver.c b/thirdparty/php83/pdo_odbc/odbc_driver.c
-index c83da646c..a5e3a8b4f 100644
---- a/thirdparty/php83/pdo_odbc/odbc_driver.c
-+++ b/thirdparty/php83/pdo_odbc/odbc_driver.c
-@@ -25,6 +25,7 @@
- #include "pdo/php_pdo.h"
- #include "pdo/php_pdo_driver.h"
- #include "zend_exceptions.h"
-+#include <php_odbc_utils.h>
-
- static void pdo_odbc_fetch_error_func(pdo_dbh_t *dbh, pdo_stmt_t *stmt, zval *info) {
- pdo_odbc_db_handle *H = (pdo_odbc_db_handle *) dbh->driver_data;
---
-2.45.1
-
diff --git a/0002-fix-implicit-int.patch b/0002-fix-implicit-int.patch
deleted file mode 100644
index 728187d..0000000
--- a/0002-fix-implicit-int.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From c127c74ba12ffb62afa653710c574f28e469e7a7 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 6 Jun 2024 10:16:26 +0200
-Subject: [PATCH 2/2] fix implicit int
-
----
- ext-src/php_swoole_call_stack.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/ext-src/php_swoole_call_stack.h b/ext-src/php_swoole_call_stack.h
-index 8c89f8305..639a303d7 100644
---- a/ext-src/php_swoole_call_stack.h
-+++ b/ext-src/php_swoole_call_stack.h
-@@ -18,8 +18,8 @@
-
- #ifdef ZEND_CHECK_STACK_LIMIT
- #define HOOK_PHP_CALL_STACK(callback) \
-- auto __stack_limit = EG(stack_limit); \
-- auto __stack_base = EG(stack_base); \
-+ void *__stack_limit = EG(stack_limit); \
-+ void *__stack_base = EG(stack_base); \
- EG(stack_base) = (void *) 0; \
- EG(stack_limit) = (void *) 0; \
- callback EG(stack_limit) = __stack_limit; \
---
-2.45.1
-
diff --git a/PHPINFO b/PHPINFO
index dbd76ac..b2edd95 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 5.1.3
-Built => Jun 6 2024 00:00:00
+Version => 5.1.4
+Built => Aug 26 2024 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index c3d8b64..ad493be 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #94 swoole version 5.1.3 ] {
+Extension [ <persistent> extension #96 swoole version 5.1.4 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -33,11 +33,11 @@ Extension [ <persistent> extension #94 swoole version 5.1.3 ] {
}
- Constants [421] {
- Constant [ string SWOOLE_VERSION ] { 5.1.3 }
- Constant [ int SWOOLE_VERSION_ID ] { 50103 }
+ Constant [ string SWOOLE_VERSION ] { 5.1.4 }
+ Constant [ int SWOOLE_VERSION_ID ] { 50104 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 5 }
Constant [ int SWOOLE_MINOR_VERSION ] { 1 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 3 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 4 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index 69e0d30..1f1ff6c 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -34,27 +34,12 @@
%endif
-%if 0%{?fedora} || 0%{?rhel} >= 8
%bcond_without pgsql
-%else
-%bcond_with pgsql
-%endif
-
-%if 0%{?fedora} || 0%{?rhel} >= 8
%bcond_without brotli
-%else
-%bcond_with brotli
-%endif
-
-%if 0%{?fedora} || 0%{?rhel} >= 8
%bcond_without curl
-%else
-%bcond_with curl
-%endif
-
%bcond_without nghttpd2
-%global upstream_version 5.1.3
+%global upstream_version 5.1.4
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -70,9 +55,6 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: 0001-missing-header.patch
-Patch1: 0002-fix-implicit-int.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -192,9 +174,6 @@ sed \
cd %{sources}
-%patch -P0 -p1
-%patch -P1 -p1
-
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
%if %{with nghttpd2}
rm -r thirdparty/nghttp2
@@ -315,26 +294,6 @@ rm %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/swoole_process/echo.py
rm %{buildroot}%{pecl_docdir}/%{pecl_name}/examples/process/echo.py
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
OPT="--no-php-ini"
[ -f %{php_extdir}/curl.so ] && OPT="$OPT -d extension=curl"
@@ -389,6 +348,10 @@ cd ../ZTS
%changelog
+* Mon Aug 26 2024 Remi Collet <remi@remirepo.net> - 5.1.4-1
+- update to 5.1.4
+- drop patch merged upstream
+
* Thu Jun 6 2024 Remi Collet <remi@remirepo.net> - 5.1.3-1
- update to 5.1.3
- fix build warnings (errors with GCC 14) using patch from