summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-swoole5.spec8
3 files changed, 13 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index 668e95d..11efdde 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 5.1.5
-Built => Oct 22 2024 00:00:00
+Version => 5.1.6
+Built => Nov 28 2024 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 9a1f249..3ceec55 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 swoole version 5.1.5 ] {
+Extension [ <persistent> extension #127 swoole version 5.1.6 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -32,12 +32,12 @@ Extension [ <persistent> extension #125 swoole version 5.1.5 ] {
}
}
- - Constants [421] {
- Constant [ string SWOOLE_VERSION ] { 5.1.5 }
- Constant [ int SWOOLE_VERSION_ID ] { 50105 }
+ - Constants [422] {
+ Constant [ string SWOOLE_VERSION ] { 5.1.6 }
+ Constant [ int SWOOLE_VERSION_ID ] { 50106 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 5 }
Constant [ int SWOOLE_MINOR_VERSION ] { 1 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 5 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 6 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -134,6 +134,7 @@ Extension [ <persistent> extension #125 swoole version 5.1.5 ] {
Constant [ int SWOOLE_ERROR_SSL_BAD_PROTOCOL ] { 1016 }
Constant [ int SWOOLE_ERROR_SSL_RESET ] { 1017 }
Constant [ int SWOOLE_ERROR_SSL_HANDSHAKE_FAILED ] { 1018 }
+ Constant [ int SWOOLE_ERROR_SSL_CREATE_CONTEXT_FAILED ] { 1019 }
Constant [ int SWOOLE_ERROR_PACKAGE_LENGTH_TOO_LARGE ] { 1201 }
Constant [ int SWOOLE_ERROR_PACKAGE_LENGTH_NOT_FOUND ] { 1202 }
Constant [ int SWOOLE_ERROR_DATA_LENGTH_TOO_LARGE ] { 1203 }
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index b820854..c583538 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -39,7 +39,7 @@
%bcond_without curl
%bcond_without nghttpd2
-%global upstream_version 5.1.5
+%global upstream_version 5.1.6
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -47,7 +47,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}5
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is Apache-2.0
# BSD-3-Clause: Hiredis
# MIT: nlohmann/json, nghttp2
@@ -58,7 +58,6 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-# See https://github.com/swoole/swoole-src/issues/5534
BuildRequires: (%{?scl_prefix}php-devel >= 8.0 with %{?scl_prefix}php-devel < 8.4)
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-curl
@@ -345,6 +344,9 @@ cd ../ZTS
%changelog
+* Thu Nov 28 2024 Remi Collet <remi@remirepo.net> - 5.1.6-1
+- update to 5.1.6
+
* Tue Nov 26 2024 Remi Collet <remi@remirepo.net> - 5.1.5-2
- drop BR on pcre-devel