summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-05-30 10:01:30 +0200
committerRemi Collet <fedora@famillecollet.com>2014-05-30 10:01:30 +0200
commite6cf34c8f0bd2ec717c92b220095cf824c503302 (patch)
treefecad5b38079a1af0d12391114905a5dea18809d
parenta606cf0f326b95b72af30d7a3d15ef294a2d1923 (diff)
php-pecl-swoole: 1.7.2 (stable)
-rw-r--r--REFLECTION63
-rw-r--r--php-pecl-swoole.spec11
2 files changed, 69 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
index 99b9ce1..9f0ce9e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,27 @@
-Extension [ <persistent> extension #135 swoole version 1.7.1 ] {
+Extension [ <persistent> extension #135 swoole version 1.7.2 ] {
- - Constants [32] {
+ - INI {
+ Entry [ swoole.task_worker_num <ALL> ]
+ Current = '0'
+ }
+ Entry [ swoole.task_ipc_mode <ALL> ]
+ Current = '0'
+ }
+ Entry [ swoole.task_auto_start <ALL> ]
+ Current = '0'
+ }
+ Entry [ swoole.message_queue_key <ALL> ]
+ Current = '0'
+ }
+ }
+
+ - Constants [35] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
+ Constant [ integer SWOOLE_IPC_UNSOCK ] { 1 }
+ Constant [ integer SWOOLE_IPC_MSGQUEUE ] { 2 }
+ Constant [ integer SWOOLE_IPC_CHANNEL ] { 3 }
Constant [ integer SWOOLE_SOCK_TCP ] { 1 }
Constant [ integer SWOOLE_SOCK_TCP6 ] { 3 }
Constant [ integer SWOOLE_SOCK_UDP ] { 2 }
@@ -32,7 +50,7 @@ Extension [ <persistent> extension #135 swoole version 1.7.1 ] {
Constant [ integer SWOOLE_HOST ] { 16 }
Constant [ integer SWOOLE_SHORT ] { 2 }
Constant [ integer SWOOLE_INT ] { 4 }
- Constant [ string SWOOLE_VERSION ] { 1.7.1 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.2 }
}
- Functions {
@@ -244,7 +262,7 @@ Extension [ <persistent> extension #135 swoole version 1.7.1 ] {
}
}
- - Classes [3] {
+ - Classes [4] {
Class [ <internal:swoole> class swoole_client ] {
- Constants [0] {
@@ -478,6 +496,43 @@ Extension [ <persistent> extension #135 swoole version 1.7.1 ] {
}
}
}
+
+ Class [ <internal:swoole> class swoole_process ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:swoole> static public method wait ] {
+ }
+
+ Method [ <internal:swoole> static public method kill ] {
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole> public method start ] {
+ }
+
+ Method [ <internal:swoole> public method write ] {
+ }
+
+ Method [ <internal:swoole> public method read ] {
+ }
+
+ Method [ <internal:swoole> public method exit ] {
+ }
+ }
+ }
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 9aea230..7be3a42 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,7 +23,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.1
+Version: 1.7.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -108,6 +108,12 @@ cp -pr NTS ZTS
cat << 'EOF' | tee %{ini_name}
; Enable %{summary} extension module
extension=%{pecl_name}.so
+
+; Configuration
+;swoole.task_worker_num = 0
+;swoole.task_ipc_mode = 0
+;swoole.task_auto_start = 0
+;swoole.message_queue_key =0
EOF
@@ -211,6 +217,9 @@ rm -rf %{buildroot}
%changelog
+* Fri May 30 2014 Remi Collet <remi@fedoraproject.org> - 1.7.2-1
+- Update to 1.7.2 (stable)
+
* Wed Apr 30 2014 Remi Collet <remi@fedoraproject.org> - 1.7.1-1
- Update to 1.7.1 (stable)