summaryrefslogtreecommitdiffstats
path: root/php-pecl-ssh2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-ssh2.spec')
-rw-r--r--php-pecl-ssh2.spec71
1 files changed, 21 insertions, 50 deletions
diff --git a/php-pecl-ssh2.spec b/php-pecl-ssh2.spec
index 08db743..35ea5df 100644
--- a/php-pecl-ssh2.spec
+++ b/php-pecl-ssh2.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-ssh2
# with SCL compatibility
#
-# Copyright (c) 2011-2023 Remi Collet
+# Copyright (c) 2011-2024 Remi Collet
#
# Fedora spec file for php-pecl-ssh2
#
@@ -25,12 +25,12 @@
Name: %{?scl_prefix}php-pecl-ssh2
Summary: Bindings for the libssh2 library
-Version: 1.4
+Version: 1.4.1
%if 0%{?gh_date}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
@@ -41,10 +41,10 @@ BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
-%if 0%{?vendeur:1} && 0%{?fedora} < 35 && 0%{?rhel} < 9
+%if 0%{?vendeur:1} && 0%{?fedora} < 39 && 0%{?rhel} < 9
%global move_to_opt 1
-BuildRequires: %{vendeur}-libssh2-devel >= 1.10
-Requires: %{vendeur}-libssh2%{?_isa} >= 1.10
+BuildRequires: %{vendeur}-libssh2-devel >= 1.11
+Requires: %{vendeur}-libssh2%{?_isa} >= 1.11
# Disable RPATH check
%global __arch_install_post /bin/true
%global __brp_check_rpaths /bin/true
@@ -52,7 +52,7 @@ Requires: %{vendeur}-libssh2%{?_isa} >= 1.10
%global ini_name 19-%{pecl_name}.ini
%else
%global move_to_opt 0
-BuildRequires: libssh2-devel >= 1.10
+BuildRequires: libssh2-devel >= 1.11
Requires: libssh2%{?_isa} >= %{buildver}
%global ini_name 40-%{pecl_name}.ini
%endif
@@ -65,20 +65,6 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%if %{move_to_opt}
%{?filter_requires_in: %filter_requires_in %{_libdir}/.*\.so$}
%endif
@@ -109,7 +95,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -140,6 +126,8 @@ mkdir ZTS
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
@@ -148,7 +136,8 @@ cd ../NTS
%endif
--with-libdir=%{_lib} \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+
+%make_build
%if %{with_zts}
cd ../ZTS
@@ -158,14 +147,15 @@ cd ../ZTS
%endif
--with-libdir=%{_lib} \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# Install XML package description
install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -174,7 +164,7 @@ install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
install -Dpm644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -Dpm644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -201,31 +191,8 @@ done
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-%if 0%{?gh_date}
-echo -e "\n** %{name} is an experimental package, built from a development sources snapshot **\n"
-%endif
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -239,6 +206,10 @@ fi
%changelog
+* Mon Feb 12 2024 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- update to 1.4.1
+- use libssh2 1.11
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.4-4
- rebuild for PHP 8.3.0RC1