summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION5
-rw-r--r--php-pecl-skywalking-agent.spec12
3 files changed, 14 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index 92f93ca..273e093 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
skywalking_agent
-version => 0.8.0
+version => 1.0.0
authors => Apache Software Foundation:jmjoy <jmjoy@apache.org>:Yanlong He <heyanlong@apache.org>
Directive => Local Value => Master Value
@@ -27,3 +27,4 @@ skywalking_agent.kafka_bootstrap_servers => no value => no value
skywalking_agent.kafka_producer_config => {} => {}
skywalking_agent.inject_context => 0 => 0
skywalking_agent.standalone_socket_path => no value => no value
+skywalking_agent.psr_logging_level => no value => no value
diff --git a/REFLECTION b/REFLECTION
index d4c1100..833b86b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 skywalking_agent version 0.8.0 ] {
+Extension [ <persistent> extension #107 skywalking_agent version 1.0.0 ] {
- INI {
Entry [ skywalking_agent.enable <SYSTEM> ]
@@ -67,6 +67,9 @@ Extension [ <persistent> extension #99 skywalking_agent version 0.8.0 ] {
Entry [ skywalking_agent.standalone_socket_path <SYSTEM> ]
Current = ''
}
+ Entry [ skywalking_agent.psr_logging_level <SYSTEM> ]
+ Current = ''
+ }
}
- Functions {
diff --git a/php-pecl-skywalking-agent.spec b/php-pecl-skywalking-agent.spec
index 2743bbd..e7769e7 100644
--- a/php-pecl-skywalking-agent.spec
+++ b/php-pecl-skywalking-agent.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-skywalking-agent
#
-# SPDX-FileCopyrightText: Copyright 2024 Remi Collet
+# SPDX-FileCopyrightText: Copyright 2022-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
@@ -18,12 +18,12 @@
%global ini_name 40-%{pecl_name}.ini
%global sources %{pecl_name}-%{version}
-## BUILD: Fedora / EL-8 and EL-9 using --enablerepo=stream if needed
+## BUILD: Fedora / no EL-8 (rust too old) / EL-9 and EL-10 using --enablerepo=stream if needed
Summary: Apache SkyWalking PHP Agent
Name: %{?scl_prefix}php-pecl-skywalking-agent
-Version: 0.8.0
+Version: 1.0.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: Apache-2.0
URL: https://pecl.php.net/package/%{pecl_name}
@@ -38,7 +38,7 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: cargo >= 1.65
+BuildRequires: cargo >= 1.85
BuildRequires: rustfmt
BuildRequires: protobuf-compiler
BuildRequires: clang-devel
@@ -133,6 +133,7 @@ extension=%{pecl_name}.so
;skywalking_agent.kafka_producer_config = {}
;skywalking_agent.inject_context = 0
;skywalking_agent.standalone_socket_path =
+;skywalking_agent.psr_logging_level =
EOF
: Required rust version
@@ -195,6 +196,9 @@ done
%changelog
+* Tue Apr 22 2025 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0
+
* Mon Dec 9 2024 Remi Collet <remi@remirepo.net> - 0.8.0-1
- update to 0.8.0
- EL-10 disable kafka reporter - broken build with OPENSSL_NO_ENGINE