summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION124
-rw-r--r--php-pecl-protobuf.spec7
3 files changed, 98 insertions, 35 deletions
diff --git a/PHPINFO b/PHPINFO
index 91be5cb..1ec77ce 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
protobuf
-Version => 4.30.2
+Version => 4.31.0RC1
Directive => Local Value => Master Value
protobuf.keep_descriptor_pool_after_request => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 2554184..df64ef2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
+Extension [ <persistent> extension #101 protobuf version 4.31.0RC1 ] {
- Dependencies {
Dependency [ date (Optional) ]
@@ -10,7 +10,7 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
}
}
- - Classes [56] {
+ - Classes [57] {
Class [ <internal:protobuf> final class Google\Protobuf\Internal\Arena ] {
- Constants [0] {
@@ -29,7 +29,7 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
}
}
- Class [ <internal:protobuf> <iterateable> final class Google\Protobuf\Internal\RepeatedField implements ArrayAccess, IteratorAggregate, Traversable, Countable ] {
+ Class [ <internal:protobuf> <iterateable> final class Google\Protobuf\RepeatedField implements ArrayAccess, IteratorAggregate, Traversable, Countable ] {
- Constants [0] {
}
@@ -453,7 +453,7 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [11] {
Method [ <internal:protobuf> public method getName ] {
- Parameters [0] {
@@ -472,6 +472,18 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
}
}
+ Method [ <internal:protobuf> public method isRequired ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:protobuf> public method isRepeated ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:protobuf> public method getType ] {
- Parameters [0] {
@@ -787,7 +799,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -977,7 +990,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -1205,7 +1219,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -1410,7 +1425,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -1550,7 +1566,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -1713,7 +1730,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -1850,7 +1868,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -2000,7 +2019,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -2150,7 +2170,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -2300,7 +2321,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -2440,7 +2462,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -2638,7 +2661,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -2765,7 +2789,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -2973,7 +2998,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -3201,7 +3227,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -3445,7 +3472,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -3722,7 +3750,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -3875,7 +3904,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4015,7 +4045,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4199,7 +4230,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4326,7 +4358,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4453,7 +4486,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4580,7 +4614,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4707,7 +4742,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4834,7 +4870,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -4961,7 +4998,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -5088,7 +5126,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -5215,7 +5254,8 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
Method [ <internal:protobuf, inherits Google\Protobuf\Internal\Message> public method serializeToJsonString ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -5279,6 +5319,26 @@ Extension [ <persistent> extension #99 protobuf version 4.30.2 ] {
}
}
}
+
+ Class [ <internal:protobuf> class Google\Protobuf\PrintOptions ] {
+
+ - Constants [2] {
+ Constant [ public int PRESERVE_PROTO_FIELD_NAMES ] { 1 }
+ Constant [ public int ALWAYS_PRINT_ENUMS_AS_INTS ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index a958176..464d73b 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -12,8 +12,8 @@
%global pecl_name protobuf
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 4.30.2
-#global upstream_prever RC2
+%global upstream_version 4.31.0
+%global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -163,6 +163,9 @@ done
%changelog
+* Tue Apr 22 2025 Remi Collet <remi@remirepo.net> - 4.31.0~RC1-1
+- update to 4.31.0RC1
+
* Thu Mar 27 2025 Remi Collet <remi@remirepo.net> - 4.30.2-1
- update to 4.30.2 (no change)