summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-phpy.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/php-pecl-phpy.spec b/php-pecl-phpy.spec
index 4d22a30..9be4941 100644
--- a/php-pecl-phpy.spec
+++ b/php-pecl-phpy.spec
@@ -22,7 +22,7 @@
Summary: An extension for inter-calling Python and PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.6
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: Apache-2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
@@ -36,7 +36,14 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.1
BuildRequires: %{?scl_prefix}php-pear
# See https://github.com/swoole/phpy/issues/63
+%if 0%{?rhel} == 8
+# Retirement date: May 2029 (Full Life)
+BuildRequires: python3.12-devel >= 3.8
+%global __usepyconf python3.12-config
+%else
BuildRequires: python3-devel >= 3.8
+%global __usepyconf python3-config
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -106,7 +113,7 @@ cd %{sources}
cd ../NTS
%configure \
--enable-phpy \
- --with-python-config=%{_root_bindir}/python3-config \
+ --with-python-config=%{_root_bindir}/%{__usepyconf} \
--with-libdir=%{_lib} \
--with-php-config=%{__phpconfig}
make %{?_smp_mflags}
@@ -115,7 +122,7 @@ make %{?_smp_mflags}
cd ../ZTS
%configure \
--enable-phpy \
- --with-python-config=%{_root_bindir}/python3-config \
+ --with-python-config=%{_root_bindir}/%{__usepyconf} \
--with-libdir=%{_lib} \
--with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
@@ -178,6 +185,10 @@ cd %{sources}
%changelog
+* Tue Aug 20 2024 Remi Collet <remi@remirepo.net> - 1.0.6-2
+- use python3.12 on EL-8
+- open https://github.com/swoole/phpy/pull/65 use PKG_CHECK_MODULES
+
* Tue Aug 20 2024 Remi Collet <remi@remirepo.net> - 1.0.6-1
- initial package
- open https://github.com/swoole/phpy/pull/61 use cxx linker