summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-25 13:00:42 +0200
committerRemi Collet <remi@php.net>2024-07-25 13:00:42 +0200
commitc0b0db808059baeda1204c3140a35b85f47e7189 (patch)
treeb12eba9e910d5c090c6a9f13977cd8be3923ad23
initial package, test build of upcoming version 1.1.0
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--php-pecl-pdo-oci.spec194
3 files changed, 207 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-pecl-pdo-oci.spec b/php-pecl-pdo-oci.spec
new file mode 100644
index 0000000..35971d9
--- /dev/null
+++ b/php-pecl-pdo-oci.spec
@@ -0,0 +1,194 @@
+# remirepo spec file for php-pecl-pdo-oci
+#
+# Copyright (c) 2024 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-pdo-oci}
+%{!?scl: %global _root_prefix %{_prefix}}
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name pdo_oci
+%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
+
+%ifarch aarch64
+%global oraclever 19.23
+%global oraclemax 20
+%global oraclelib 19.1
+%global oracledir 19.23
+%else
+%global oraclever 23.5
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
+%endif
+%global with_dtrace 1
+
+
+Summary: PDO driver for Oracle Database
+Name: %{?scl_prefix}php-pecl-pdo-oci
+Version: 1.1.0
+Release: 0.1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+
+License: PHP-3.01
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+BuildRequires: %{?scl_prefix}php-devel >= 8.3
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-pdo
+%if %{with_dtrace}
+BuildRequires: systemtap-sdt-devel
+%endif
+%ifarch aarch64
+BuildRequires: oracle-instantclient%{oraclever}-devel
+# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
+Requires: libclntsh.so.%{oraclelib}
+AutoReq: 0
+%else
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
+%endif
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+%if "%{php_version}" < "8.4"
+Conflicts: %{?scl_prefix}php-oci8 < 8.4
+%endif
+Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+
+%description
+The PDO_OCI extension provides the driver to access Oracle Database.
+
+The extension is linked with Oracle client libraries %{oraclever}
+(Oracle Instant Client). For details, see Oracle's note
+"Oracle Client / Server Interoperability Support" (ID 207303.1).
+
+You must install libclntsh.so.%{oraclelib} to use this package,
+provided by Oracle Instant Client RPM available from Oracle on:
+https://www.oracle.com/database/technologies/instant-client/downloads.html
+
+Documentation is at https://php.net/oci8
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+# don't install tests
+sed -e 's/role="test"/role="src"/' \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
+ -i package.xml
+
+cd %{sources}
+# Check reported version (phpinfo), as this is often broken
+extver=$(sed -n '/#define PHP_PDO_OCI_VERSION/{s/.* "//;s/".*$//;p}' php_pdo_oci.h)
+if test "x${extver}" != "x%{version}%{?versuffix}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+# Drop in the bit of configuration
+cat > %{ini_name} << 'EOF'
+; Enable %{summary}
+extension = %{pecl_name}.so
+
+EOF
+
+mkdir NTS
+%if %{with_zts}
+mkdir ZTS
+%endif
+
+
+%build
+%{?dtsenable}
+
+%if %{with_dtrace}
+export PHP_DTRACE=yes
+%endif
+
+peclconf() {
+%configure \
+ --with-pdo-oci=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
+ --with-php-config=$1
+}
+
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+peclconf %{__phpconfig}
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+peclconf %{__ztsphpconfig}
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=pdo \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^PDO_OCI$'
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=pdo \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^PDO_OCI$'
+%endif
+
+
+%files
+%license %{sources}/LICENSE
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Thu Jul 25 2024 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- initial package, test build of upcoming version 1.1.0