summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION141
-rw-r--r--php-pecl-parallel.spec30
3 files changed, 91 insertions, 82 deletions
diff --git a/PHPINFO b/PHPINFO
index 3ae82f1..eeadf7d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
parallel
parallel support => enabled
-parallel version => 1.2.1
+parallel version => 1.2.2
diff --git a/REFLECTION b/REFLECTION
index 8c961c9..8d354ee 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
+Extension [ <persistent> extension #83 parallel version 1.2.2 ] {
- Functions {
Function [ <internal:parallel> function parallel\bootstrap ] {
@@ -38,8 +38,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -56,6 +56,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -129,8 +130,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -147,6 +148,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -220,8 +222,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -238,6 +240,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -311,8 +314,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -329,6 +332,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -402,8 +406,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -420,6 +424,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -493,8 +498,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -511,6 +516,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -584,8 +590,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -602,6 +608,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -675,8 +682,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -693,6 +700,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -766,8 +774,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -784,6 +792,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -857,8 +866,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -875,6 +884,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -948,8 +958,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -966,6 +976,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1039,8 +1050,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1057,6 +1068,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1130,8 +1142,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1148,6 +1160,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1221,8 +1234,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1239,6 +1252,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1312,8 +1326,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1330,6 +1344,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1403,8 +1418,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1421,6 +1436,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1494,8 +1510,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1512,6 +1528,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1585,8 +1602,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1603,6 +1620,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1676,8 +1694,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1694,6 +1712,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1767,8 +1786,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1785,6 +1804,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1858,8 +1878,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1876,6 +1896,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -1949,8 +1970,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -1967,6 +1988,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -2040,8 +2062,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -2058,6 +2080,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -2131,8 +2154,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -2149,6 +2172,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -2222,8 +2246,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -2240,6 +2264,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -2313,8 +2338,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -2331,6 +2356,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -2404,8 +2430,8 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line ]
}
- Methods [10] {
@@ -2422,6 +2448,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Error, prototype Throwable> final public method getMessage ] {
@@ -2678,7 +2705,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Tentative return [ string ]
}
}
}
@@ -2758,7 +2785,7 @@ Extension [ <persistent> extension #124 parallel version 1.2.1 ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Tentative return [ int ]
}
}
}
diff --git a/php-pecl-parallel.spec b/php-pecl-parallel.spec
index 7b3093c..b854b08 100644
--- a/php-pecl-parallel.spec
+++ b/php-pecl-parallel.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-parallel
#
-# Copyright (c) 2019-2022 Remi Collet
+# Copyright (c) 2019-2024 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -15,11 +15,11 @@
Summary: Parallel concurrency API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?scl_prefix}php-zts-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
@@ -29,7 +29,6 @@ BuildRequires: autoconf
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -102,26 +101,6 @@ do sed -e 's/\r//' -i $i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd %{pecl_name}-%{version}
@@ -149,6 +128,9 @@ SKIP_ONLINE_TESTS=1 \
%changelog
+* Mon Jul 1 2024 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+
* Sat Oct 29 2022 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1