summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-parallel.spec49
3 files changed, 38 insertions, 25 deletions
diff --git a/PHPINFO b/PHPINFO
index 25e04de..1f19b02 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
parallel
parallel support => enabled
-parallel version => 1.2.4
+parallel version => 1.2.5
diff --git a/REFLECTION b/REFLECTION
index f185b27..1ed1b44 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #112 parallel version 1.2.4 ] {
+Extension [ <persistent> extension #124 parallel version 1.2.5 ] {
- Functions {
Function [ <internal:parallel> function parallel\bootstrap ] {
@@ -2724,7 +2724,7 @@ Extension [ <persistent> extension #112 parallel version 1.2.4 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:parallel> public method setInput ] {
- Parameters [1] {
@@ -2766,6 +2766,14 @@ Extension [ <persistent> extension #112 parallel version 1.2.4 ] {
- Return [ void ]
}
+ Method [ <internal:parallel> public method setBlocker ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $blocker ]
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:parallel> public method setTimeout ] {
- Parameters [1] {
diff --git a/php-pecl-parallel.spec b/php-pecl-parallel.spec
index 9506aab..63bf6d1 100644
--- a/php-pecl-parallel.spec
+++ b/php-pecl-parallel.spec
@@ -12,14 +12,15 @@
%global pecl_name parallel
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
Summary: Parallel concurrency API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.2.4
+Version: 1.2.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: %{?scl_prefix}php-zts-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
@@ -54,7 +55,7 @@ sed -e 's/role="test"/role="src"/' \
-e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
-cd %{pecl_name}-%{version}
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/define PHP_PARALLEL_VERSION/{s/.* "//;s/".*$//;p}' php_parallel.h)
@@ -72,29 +73,31 @@ EOF
%build
-%{?dtsenable}
+cd %{sources}
+
+%{__ztsphpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
-cd %{pecl_name}-%{version}
-%{_bindir}/zts-phpize
%configure \
--enable-parallel \
- --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
+ --with-php-config=%{__ztsphpconfig}
+
+%make_build
%install
-%{?dtsenable}
+cd %{sources}
-make -C %{pecl_name}-%{version} install INSTALL_ROOT=%{buildroot}
+: Install the extension
+%make_install
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+: Install config file
+install -D -m 644 ../%{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+: Install XML package description
+install -D -m 644 ../package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-# Documentation
-cd %{pecl_name}-%{version}
+: INstall Documentation
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do sed -e 's/\r//' -i $i
install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
@@ -102,24 +105,23 @@ done
%check
-cd %{pecl_name}-%{version}
+cd %{sources}
-: Minimal load test for ZTS extension
+: Minimal load test for the extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+: Upstream test suite for the extension
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
SKIP_ONLINE_TESTS=1 \
-%{_bindir}/zts-php -n -q run-tests.php --show-diff %{?_smp_mflags}
+%{__ztsphp} -n -q run-tests.php --show-diff %{?_smp_mflags}
%endif
%files
-%license %{pecl_name}-%{version}/LICENSE
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -128,6 +130,9 @@ SKIP_ONLINE_TESTS=1 \
%changelog
+* Mon Nov 4 2024 Remi Collet <remi@remirepo.net> - 1.2.5-1
+- update to 1.2.5
+
* Mon Aug 26 2024 Remi Collet <remi@remirepo.net> - 1.2.4-1
- update to 1.2.4