summaryrefslogtreecommitdiffstats
path: root/php-pecl-opentelemetry.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-opentelemetry.spec')
-rw-r--r--php-pecl-opentelemetry.spec41
1 files changed, 27 insertions, 14 deletions
diff --git a/php-pecl-opentelemetry.spec b/php-pecl-opentelemetry.spec
index 7195a6c..14f8dbd 100644
--- a/php-pecl-opentelemetry.spec
+++ b/php-pecl-opentelemetry.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-opentelemetry
#
-# Copyright (c) 2023-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2023-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -14,8 +14,8 @@
%global pecl_name opentelemetry
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.1.0
-%global upstream_prever beta2
+%global upstream_version 1.1.2
+#global upstream_prever beta3
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -89,6 +89,7 @@ extension=%{pecl_name}.so
;opentelemetry.validate_hook_functions = On
;opentelemetry.allow_stack_extension = Off
;opentelemetry.attr_hooks_enabled = Off
+;opentelemetry.display_warnings = Off
;opentelemetry.attr_pre_handler_function =OpenTelemetry\API\Instrumentation\WithSpanHandler::pre
;opentelemetry.attr_post_handler_function = OpenTelemetry\API\Instrumentation\WithSpanHandler::post
EOF
@@ -99,26 +100,29 @@ EOF
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
%configure \
--enable-opentelemetry \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--enable-opentelemetry \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -127,7 +131,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -149,11 +153,8 @@ cd %{sources}
%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
@@ -165,7 +166,6 @@ REPORT_EXIT_STATUS=1 \
%files
-#%%doc %%{pecl_docdir}/%%{pecl_name}
%license %{sources}/LICENSE*
%{pecl_xmldir}/%{name}.xml
@@ -179,6 +179,19 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Jan 23 2025 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+
+* Tue Jan 21 2025 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+- re-license spec file to CECILL-2.1
+
+* Thu Oct 3 2024 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
+* Tue Sep 10 2024 Remi Collet <remi@remirepo.net> - 1.1.0~beta3-1
+- update to 1.1.0beta3
+
* Wed Sep 4 2024 Remi Collet <remi@remirepo.net> - 1.1.0~beta2-1
- update to 1.1.0beta2
- open https://github.com/open-telemetry/opentelemetry-php/issues/1376 PHP 8.4 compatibility