summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-opentelemetry.spec17
3 files changed, 13 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index f6d9c97..9cc570c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
opentelemetry
opentelemetry hooks => enabled
-extension version => 1.1.0beta3
+extension version => 1.1.0
Directive => Local Value => Master Value
opentelemetry.conflicts => no value => no value
diff --git a/REFLECTION b/REFLECTION
index b83ce9c..66829c7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #87 opentelemetry version 1.1.0beta3 ] {
+Extension [ <persistent> extension #89 opentelemetry version 1.1.0 ] {
- INI {
Entry [ opentelemetry.conflicts <ALL> ]
diff --git a/php-pecl-opentelemetry.spec b/php-pecl-opentelemetry.spec
index f50150a..7c4b323 100644
--- a/php-pecl-opentelemetry.spec
+++ b/php-pecl-opentelemetry.spec
@@ -15,7 +15,7 @@
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 1.1.0
-%global upstream_prever beta3
+#global upstream_prever beta3
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -99,26 +99,29 @@ EOF
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
%configure \
--enable-opentelemetry \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--enable-opentelemetry \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -127,7 +130,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -165,7 +168,6 @@ REPORT_EXIT_STATUS=1 \
%files
-#%%doc %%{pecl_docdir}/%%{pecl_name}
%license %{sources}/LICENSE*
%{pecl_xmldir}/%{name}.xml
@@ -179,6 +181,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Oct 3 2024 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Tue Sep 10 2024 Remi Collet <remi@remirepo.net> - 1.1.0~beta3-1
- update to 1.1.0beta3