summaryrefslogtreecommitdiffstats
path: root/php-pecl-imap.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-imap.spec')
-rw-r--r--php-pecl-imap.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-pecl-imap.spec b/php-pecl-imap.spec
index 906cab9..ca58e0b 100644
--- a/php-pecl-imap.spec
+++ b/php-pecl-imap.spec
@@ -20,7 +20,7 @@
Summary: Extension to operate with the IMAP protocol
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.2
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
@@ -99,31 +99,32 @@ peclconf() {
}
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
peclconf %{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
peclconf %{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -179,7 +180,7 @@ fi
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -193,6 +194,9 @@ fi
%changelog
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.0.2-4
+- rebuild for 8.4.0RC1
+
* Thu Jul 4 2024 Remi Collet <remi@remirepo.net> - 1.0.2-3
- add upstream patch for PHP 8.4