summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-imap.spec5
-rw-r--r--upstream.patch27
2 files changed, 31 insertions, 1 deletions
diff --git a/php-pecl-imap.spec b/php-pecl-imap.spec
index 06c1dc1..906cab9 100644
--- a/php-pecl-imap.spec
+++ b/php-pecl-imap.spec
@@ -20,7 +20,7 @@
Summary: Extension to operate with the IMAP protocol
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
@@ -193,6 +193,9 @@ fi
%changelog
+* Thu Jul 4 2024 Remi Collet <remi@remirepo.net> - 1.0.2-3
+- add upstream patch for PHP 8.4
+
* Thu Jan 4 2024 Remi Collet <remi@remirepo.net> - 1.0.2-2
- add upstream patch to report extension version
diff --git a/upstream.patch b/upstream.patch
index 36f1b29..866cdd3 100644
--- a/upstream.patch
+++ b/upstream.patch
@@ -1,3 +1,30 @@
+From 4fc9970a29c205ec328f36edc8c119c158129324 Mon Sep 17 00:00:00 2001
+From: Niels Dossche <7771979+nielsdos@users.noreply.github.com>
+Date: Sun, 4 Feb 2024 19:59:07 +0100
+Subject: [PATCH] Fix #5: Build with php-src master is broken
+
+---
+ php_imap.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/php_imap.c b/php_imap.c
+index 38b11b8..df2f8dd 100644
+--- a/php_imap.c
++++ b/php_imap.c
+@@ -806,8 +806,13 @@ PHP_FUNCTION(imap_append)
+ }
+
+ zend_string_release(regex);
++#if PHP_VERSION_ID >= 80400
++ php_pcre_match_impl(pce, internal_date, return_value, subpats, global,
++ Z_L(0), Z_L(0));
++#else
+ php_pcre_match_impl(pce, internal_date, return_value, subpats, global,
+ 0, Z_L(0), Z_L(0));
++#endif
+
+ if (!Z_LVAL_P(return_value)) {
+ // TODO Promoto to error?
From 65de3c0c338642a88edf82335a78bb521c8d123a Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Thu, 4 Jan 2024 11:35:52 +0100