summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-ice.spec96
3 files changed, 50 insertions, 60 deletions
diff --git a/PHPINFO b/PHPINFO
index 40226e0..ee8592a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
ice
-Simple and fast PHP framework frozen in C extension.<br>Copyright (c) 2014-2023 Ice Team.
+Simple and fast PHP framework frozen in C extension.<br>Copyright (c) 2014-2025 Ice Team.
ice => enabled
Author => Ice Team
-Version => 1.10.1
-Build Date => Feb 20 2023 00:00:00
-Powered by Zephir => Version 0.17.0-$Id$
+Version => 1.11.0
+Build Date => Jan 27 2025 00:00:00
+Powered by Zephir => Version 0.18.0-$Id$
homepage => https://www.iceframework.org
email => info@iceframework.org
diff --git a/REFLECTION b/REFLECTION
index 008837e..02e06d7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 ice version 1.10.1 ] {
+Extension [ <persistent> extension #82 ice version 1.11.0 ] {
- Dependencies {
}
@@ -15955,8 +15955,8 @@ Extension [ <persistent> extension #122 ice version 1.10.1 ] {
Constant [ public int RC ] { 3 }
Constant [ public int STABLE ] { 4 }
Constant [ public int MAJOR ] { 1 }
- Constant [ public int MINOR ] { 10 }
- Constant [ public int PATCH ] { 1 }
+ Constant [ public int MINOR ] { 11 }
+ Constant [ public int PATCH ] { 0 }
Constant [ public int STAGE ] { 4 }
Constant [ public int BUILD ] { 0 }
}
diff --git a/php-pecl-ice.spec b/php-pecl-ice.spec
index 83cac30..594ab07 100644
--- a/php-pecl-ice.spec
+++ b/php-pecl-ice.spec
@@ -1,35 +1,34 @@
# remirepo spec file for php-pecl-ice
#
-# Copyright (c) 2020-2023 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2020-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-ice
-%endif
+%{?scl:%scl_package php-pecl-ice}
-%global pecl_name ice
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name ice
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 20-json and 20-pdo
-%global ini_name 40-%{pecl_name}.ini
+%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.10.1
+%global upstream_version 1.11.0
#global upstream_prever alpha3
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
Summary: Simple and fast PHP framework
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.4
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
@@ -38,7 +37,6 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-pdo%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -59,12 +57,10 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
-mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
-
-cd NTS
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ICE_VERSION/{s/.* "//;s/".*$//;p}' php_ice.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -73,9 +69,9 @@ if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -91,31 +87,36 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+# see https://github.com/ice/framework/issues/315
+export CFLAGS="%{optflags} -Wno-incompatible-pointer-types"
+
+cd %{sources}
+%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
+
+cd ../NTS
%configure \
--enable-ice \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--enable-ice \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -124,41 +125,21 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd NTS
: Minimal load test for NTS extension
-%{_bindir}/php --no-php-ini \
+%{__php} --no-php-ini \
--define extension=json.so \
--define extension=pdo.so \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
@@ -176,7 +157,7 @@ cd ../ZTS
%files
-%{?_licensedir:%license NTS/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -190,6 +171,15 @@ cd ../ZTS
%changelog
+* Mon Jan 27 2025 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+- re-license spec file to CECILL-2.1
+
+* Mon Feb 19 2024 Remi Collet <remi@remirepo.net> - 1.10.1-2
+- ignore incompatible-pointer-types errors, reported as
+ https://github.com/ice/framework/issues/315
+- build out of sources tree
+
* Mon Feb 20 2023 Remi Collet <remi@remirepo.net> - 1.10.1-1
- update to 1.10.1