summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION95
-rw-r--r--php-pecl-ice.spec99
3 files changed, 103 insertions, 99 deletions
diff --git a/PHPINFO b/PHPINFO
index d684398..ee8592a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
ice
-Simple and fast PHP framework frozen in C extension.<br>Copyright (c) 2014-2023 Ice Team.
+Simple and fast PHP framework frozen in C extension.<br>Copyright (c) 2014-2025 Ice Team.
ice => enabled
Author => Ice Team
-Version => 1.10.0
-Build Date => Feb 13 2023 00:00:00
-Powered by Zephir => Version 0.16.3-$Id$
+Version => 1.11.0
+Build Date => Jan 27 2025 00:00:00
+Powered by Zephir => Version 0.18.0-$Id$
homepage => https://www.iceframework.org
email => info@iceframework.org
diff --git a/REFLECTION b/REFLECTION
index 344ccf2..02e06d7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #77 ice version 1.10.0 ] {
+Extension [ <persistent> extension #82 ice version 1.11.0 ] {
- Dependencies {
}
@@ -887,6 +887,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, prototype ArrayAccess> public method offsetSet ] {
@@ -973,7 +974,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Class [ <internal:ice> <iterateable> abstract class Ice\Mvc\Model extends Ice\Arr implements Traversable, IteratorAggregate, Countable, ArrayAccess, Serializable ] {
+ Class [ <internal:ice> <iterateable> abstract class Ice\Mvc\Model extends Ice\Arr implements Traversable, IteratorAggregate, Countable, ArrayAccess ] {
- Constants [3] {
Constant [ public int BELONGS_TO ] { 1 }
@@ -1284,19 +1285,18 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Method [ <internal:ice, prototype Serializable> public method serialize ] {
+ Method [ <internal:ice> public method __serialize ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ array ]
}
- Method [ <internal:ice, prototype Serializable> public method unserialize ] {
+ Method [ <internal:ice> public method __unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> string $serialized ]
+ Parameter #0 [ <required> array $serialized ]
}
- - Return [ void ]
}
Method [ <internal:ice> public method __call ] {
@@ -1448,6 +1448,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -1779,6 +1780,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -1871,7 +1873,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
Method [ <internal:ice> protected method completeLogin ] {
- Parameters [2] {
- Parameter #0 [ <required> $user ]
+ Parameter #0 [ <required> string $user ]
Parameter #1 [ <optional> array $roles = [] ]
}
}
@@ -2633,6 +2635,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -3558,7 +3561,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
Method [ <internal:ice, inherits Ice\Auth\Driver> protected method completeLogin ] {
- Parameters [2] {
- Parameter #0 [ <required> $user ]
+ Parameter #0 [ <required> string $user ]
Parameter #1 [ <optional> array $roles = [] ]
}
}
@@ -3604,7 +3607,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Roles extends Ice\Mvc\Model implements Serializable, ArrayAccess, Countable, IteratorAggregate, Traversable ] {
+ Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Roles extends Ice\Mvc\Model implements ArrayAccess, Countable, IteratorAggregate, Traversable ] {
- Constants [3] {
Constant [ public int BELONGS_TO ] { 1 }
@@ -3922,19 +3925,18 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method serialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __serialize ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ array ]
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method unserialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> string $serialized ]
+ Parameter #0 [ <required> array $serialized ]
}
- - Return [ void ]
}
Method [ <internal:ice, inherits Ice\Mvc\Model> public method __call ] {
@@ -4086,6 +4088,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -4139,7 +4142,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Roles\Users extends Ice\Mvc\Model implements Serializable, ArrayAccess, Countable, IteratorAggregate, Traversable ] {
+ Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Roles\Users extends Ice\Mvc\Model implements ArrayAccess, Countable, IteratorAggregate, Traversable ] {
- Constants [3] {
Constant [ public int BELONGS_TO ] { 1 }
@@ -4458,19 +4461,18 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method serialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __serialize ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ array ]
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method unserialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> string $serialized ]
+ Parameter #0 [ <required> array $serialized ]
}
- - Return [ void ]
}
Method [ <internal:ice, inherits Ice\Mvc\Model> public method __call ] {
@@ -4622,6 +4624,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -4675,7 +4678,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Users extends Ice\Mvc\Model implements Serializable, ArrayAccess, Countable, IteratorAggregate, Traversable ] {
+ Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Users extends Ice\Mvc\Model implements ArrayAccess, Countable, IteratorAggregate, Traversable ] {
- Constants [3] {
Constant [ public int BELONGS_TO ] { 1 }
@@ -5009,19 +5012,18 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method serialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __serialize ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ array ]
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method unserialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> string $serialized ]
+ Parameter #0 [ <required> array $serialized ]
}
- - Return [ void ]
}
Method [ <internal:ice, inherits Ice\Mvc\Model> public method __call ] {
@@ -5173,6 +5175,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -5226,7 +5229,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Users\Social extends Ice\Mvc\Model implements Serializable, ArrayAccess, Countable, IteratorAggregate, Traversable ] {
+ Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Users\Social extends Ice\Mvc\Model implements ArrayAccess, Countable, IteratorAggregate, Traversable ] {
- Constants [3] {
Constant [ public int BELONGS_TO ] { 1 }
@@ -5550,19 +5553,18 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method serialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __serialize ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ array ]
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method unserialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> string $serialized ]
+ Parameter #0 [ <required> array $serialized ]
}
- - Return [ void ]
}
Method [ <internal:ice, inherits Ice\Mvc\Model> public method __call ] {
@@ -5714,6 +5716,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -5767,7 +5770,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Users\Tokens extends Ice\Mvc\Model implements Serializable, ArrayAccess, Countable, IteratorAggregate, Traversable ] {
+ Class [ <internal:ice> <iterateable> class Ice\Auth\Driver\Model\Users\Tokens extends Ice\Mvc\Model implements ArrayAccess, Countable, IteratorAggregate, Traversable ] {
- Constants [3] {
Constant [ public int BELONGS_TO ] { 1 }
@@ -6098,19 +6101,18 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
}
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method serialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __serialize ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ array ]
}
- Method [ <internal:ice, inherits Ice\Mvc\Model, prototype Serializable> public method unserialize ] {
+ Method [ <internal:ice, inherits Ice\Mvc\Model> public method __unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> string $serialized ]
+ Parameter #0 [ <required> array $serialized ]
}
- - Return [ void ]
}
Method [ <internal:ice, inherits Ice\Mvc\Model> public method __call ] {
@@ -6262,6 +6264,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -7963,6 +7966,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -8180,6 +8184,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -9202,6 +9207,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -9549,7 +9555,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
Method [ <internal:ice> protected method doSanitize ] {
- Parameters [2] {
- Parameter #0 [ <required> string $value ]
+ Parameter #0 [ <required> $value ]
Parameter #1 [ <required> string $filter ]
}
}
@@ -10117,6 +10123,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -10639,6 +10646,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -11425,7 +11433,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [3] {
Parameter #0 [ <required> string $prefix ]
- Parameter #1 [ <required> string $baseDir ]
+ Parameter #1 [ <optional> ?string $baseDir = <default> ]
Parameter #2 [ <optional> bool $prepend = <default> ]
}
}
@@ -13233,6 +13241,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -13836,6 +13845,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -14091,6 +14101,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
}
+ - Return [ mixed ]
}
Method [ <internal:ice, inherits Ice\Arr, prototype ArrayAccess> public method offsetSet ] {
@@ -15944,7 +15955,7 @@ Extension [ <persistent> extension #77 ice version 1.10.0 ] {
Constant [ public int RC ] { 3 }
Constant [ public int STABLE ] { 4 }
Constant [ public int MAJOR ] { 1 }
- Constant [ public int MINOR ] { 10 }
+ Constant [ public int MINOR ] { 11 }
Constant [ public int PATCH ] { 0 }
Constant [ public int STAGE ] { 4 }
Constant [ public int BUILD ] { 0 }
diff --git a/php-pecl-ice.spec b/php-pecl-ice.spec
index 7ba724b..594ab07 100644
--- a/php-pecl-ice.spec
+++ b/php-pecl-ice.spec
@@ -1,35 +1,34 @@
# remirepo spec file for php-pecl-ice
#
-# Copyright (c) 2020-2023 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2020-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-ice
-%endif
+%{?scl:%scl_package php-pecl-ice}
-%global pecl_name ice
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name ice
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 20-json and 20-pdo
-%global ini_name 40-%{pecl_name}.ini
+%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.10.0
+%global upstream_version 1.11.0
#global upstream_prever alpha3
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
Summary: Simple and fast PHP framework
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.4
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
@@ -38,7 +37,6 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-pdo%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -59,12 +57,10 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
-mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
-
-cd NTS
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ICE_VERSION/{s/.* "//;s/".*$//;p}' php_ice.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -73,9 +69,9 @@ if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -91,31 +87,36 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+# see https://github.com/ice/framework/issues/315
+export CFLAGS="%{optflags} -Wno-incompatible-pointer-types"
+
+cd %{sources}
+%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
+
+cd ../NTS
%configure \
--enable-ice \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--enable-ice \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -124,41 +125,21 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd NTS
: Minimal load test for NTS extension
-%{_bindir}/php --no-php-ini \
+%{__php} --no-php-ini \
--define extension=json.so \
--define extension=pdo.so \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
@@ -176,7 +157,7 @@ cd ../ZTS
%files
-%{?_licensedir:%license NTS/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -190,6 +171,18 @@ cd ../ZTS
%changelog
+* Mon Jan 27 2025 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+- re-license spec file to CECILL-2.1
+
+* Mon Feb 19 2024 Remi Collet <remi@remirepo.net> - 1.10.1-2
+- ignore incompatible-pointer-types errors, reported as
+ https://github.com/ice/framework/issues/315
+- build out of sources tree
+
+* Mon Feb 20 2023 Remi Collet <remi@remirepo.net> - 1.10.1-1
+- update to 1.10.1
+
* Mon Feb 13 2023 Remi Collet <remi@remirepo.net> - 1.10.0-1
- update to 1.10.0