summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec32
1 files changed, 9 insertions, 23 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 5ecc929..793b4c2 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -51,7 +51,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -63,6 +63,7 @@ URL: https://pecl.php.net/package/pecl_http
Source1: %{proj_name}.ini
Patch0: %{proj_name}-build.patch
+Patch1: %{proj_name}-php84.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -133,10 +134,11 @@ These are the files needed to compile programs using HTTP extension.
mv NTS/package.xml .
%endif
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
%patch -P0 -p1
+%patch -P1 -p1
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
@@ -279,28 +281,8 @@ TEST_PHP_ARGS="-n $modules -d extension=$PWD/../ZTS/modules/%{pecl_name}.so" \
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{proj_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{proj_name}
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -321,6 +303,10 @@ fi
%changelog
+* Tue Jul 9 2024 Remi Collet <remi@remirepo.net> - 4.2.4-5
+- Fix build with PHP 8.4 using patch from
+ https://github.com/m6w6/ext-http/pull/135
+
* Mon Jan 29 2024 Remi Collet <remi@remirepo.net> - 4.2.4-4
- Fix incompatible pointer types using patch from
https://github.com/m6w6/ext-http/pull/134