summaryrefslogtreecommitdiffstats
path: root/php-pecl-gnupg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-gnupg.spec')
-rw-r--r--php-pecl-gnupg.spec31
1 files changed, 23 insertions, 8 deletions
diff --git a/php-pecl-gnupg.spec b/php-pecl-gnupg.spec
index b78c13d..8397c34 100644
--- a/php-pecl-gnupg.spec
+++ b/php-pecl-gnupg.spec
@@ -1,19 +1,25 @@
# spec file for php-pecl-gnupg
#
-# Copyright (c) 2012-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2012-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
%{?scl:%scl_package php-pecl-gnupg}
+%if 0%{?fedora} >= 41
+# TODO needs investigation
+# fails in mock, succeeds in local build
+%bcond_with tests
+%else
%bcond_without tests
+%endif
%global pecl_name gnupg
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.5.1
+%global upstream_version 1.5.2
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -21,11 +27,14 @@
Summary: Wrapper around the gpgme library
Name: %{?scl_prefix}php-pecl-gnupg
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD-2-Clause
URL: https://pecl.php.net/package/gnupg
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source1: https://raw.githubusercontent.com/php-gnupg/php-gnupg/refs/tags/gnupg-%{upstream_version}/tests/no_uid_hint_msg.gpg
+
+Patch0: %{pecl_name}-tests.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -68,6 +77,9 @@ extension=%{pecl_name}.so
EOF
cd %{sources}
+cp %{SOURCE1} tests/
+%patch -P0 -p1
+
# Check extension version
extver=$(sed -n '/#define PHP_GNUPG_VERSION/{s/.* "//;s/".*$//;p}' php_gnupg.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -136,9 +148,6 @@ done
%check
cd %{sources}
-sed -e '/GnuPG v1/d' \
- -i tests/gnupg_*_export.phpt
-
unset GPG_AGENT_INFO
: Check if build NTS extension can be loaded
@@ -183,6 +192,12 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Apr 8 2025 Remi Collet <remi@remirepo.net> - 1.5.2-1
+- update to 1.5.2
+- re-license spec file to CECILL-2.1
+- open https://github.com/php-gnupg/php-gnupg/pull/52 file missing in archive
+- open https://github.com/php-gnupg/php-gnupg/pull/53 fix tests with PHP 5
+
* Tue Oct 1 2024 Remi Collet <remi@remirepo.net> - 1.5.1-4
- ignore test suite on F41