summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-gearman.spec45
3 files changed, 13 insertions, 38 deletions
diff --git a/PHPINFO b/PHPINFO
index 3f35709..ae94639 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
gearman
gearman support => enabled
-extension version => 2.1.2
-libgearman version => 1.1.20
+extension version => 2.1.3
+libgearman version => 1.1.21
Default TCP Host => localhost
Default TCP Port => 4730
diff --git a/REFLECTION b/REFLECTION
index 49efe03..dedd494 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #72 gearman version 2.1.2 ] {
+Extension [ <persistent> extension #78 gearman version 2.1.3 ] {
- Constants [157] {
Constant [ string GEARMAN_DEFAULT_TCP_HOST ] { localhost }
diff --git a/php-pecl-gearman.spec b/php-pecl-gearman.spec
index 802c8b8..30050dc 100644
--- a/php-pecl-gearman.spec
+++ b/php-pecl-gearman.spec
@@ -18,7 +18,7 @@
%bcond_without tests
-%global extver 2.1.2
+%global extver 2.1.3
%global libver 1.1.0
Name: %{?scl_prefix}php-pecl-gearman
@@ -47,13 +47,6 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
-# Other third party repo stuff
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-
%description
This extension uses libgearman library to provide API for
@@ -86,8 +79,6 @@ cat >%{ini_name} <<EOF
extension=%{pecl_name}.so
EOF
-find %{sources} -type f -exec chmod -x {} \;
-
mkdir NTS
%if %{with_zts}
mkdir ZTS
@@ -99,22 +90,24 @@ mkdir ZTS
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure --with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
%configure --with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# Install XML package description
install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -123,7 +116,7 @@ install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
install -Dpm644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -Dpm644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -156,28 +149,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -191,6 +163,9 @@ fi
%changelog
+* Tue Jan 7 2025 Remi Collet <remi@remirepo.net> - 2.1.3-1
+- update to 2.1.3 (no change)
+
* Thu Apr 4 2024 Remi Collet <remi@remirepo.net> - 2.1.2-1
- update to 2.1.2