summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION127
-rw-r--r--php-pecl-couchbase4.spec30
3 files changed, 145 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 057e546..5e1b1fe 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase => enabled
-couchbase_extension_version => 4.2.1
-couchbase_extension_revision => 321e898b6a9e3bdabfc176d72940eb1a6ab47912
-couchbase_client_revision => 1b506b0eb2d88725f943aa62527ff604610ba680
+couchbase_extension_version => 4.2.4
+couchbase_extension_revision => 763e1dc8877e67522a10a82f1d245af0b8df73dd
+couchbase_client_revision => b7086c059659d3f1e03a8d9bff266fad0c6c9b89
Directive => Local Value => Master Value
couchbase.max_persistent => -1 => -1
diff --git a/REFLECTION b/REFLECTION
index f8cd673..43ed841 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #96 couchbase version 4.2.1 ] {
+Extension [ <persistent> extension #115 couchbase version 4.2.4 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -295,7 +295,7 @@ Extension [ <persistent> extension #96 couchbase version 4.2.1 ] {
Parameter #4 [ <optional> array $scan_type = <default> ]
Parameter #5 [ <optional> ?array $options = <default> ]
}
- - Return [ null ]
+ - Return [ mixed ]
}
Function [ <internal:couchbase> function Couchbase\Extension\documentScanNextItem ] {
@@ -428,7 +428,7 @@ Extension [ <persistent> extension #96 couchbase version 4.2.1 ] {
Parameter #0 [ <optional> $connection = <default> ]
Parameter #1 [ <optional> ?array $configuration = <default> ]
}
- - Return [ null ]
+ - Return [ mixed ]
}
Function [ <internal:couchbase> function Couchbase\Extension\createTransactionContext ] {
@@ -436,7 +436,7 @@ Extension [ <persistent> extension #96 couchbase version 4.2.1 ] {
Parameter #0 [ <optional> $transactions = <default> ]
Parameter #1 [ <optional> ?array $configuration = <default> ]
}
- - Return [ null ]
+ - Return [ mixed ]
}
Function [ <internal:couchbase> function Couchbase\Extension\transactionNewAttempt ] {
@@ -1022,6 +1022,125 @@ Extension [ <persistent> extension #96 couchbase version 4.2.1 ] {
Parameter #4 [ <optional> ?array $options = <default> ]
}
}
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsDataverseCreate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $dataverseName ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsDataverseDrop ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $dataverseName ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsDatasetCreate ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $datasetName ]
+ Parameter #2 [ <required> string $bucketName ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsDatasetDrop ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $datasetName ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsDatasetGetAll ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsIndexCreate ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $datasetName ]
+ Parameter #2 [ <required> string $indexName ]
+ Parameter #3 [ <required> array $fields ]
+ Parameter #4 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsIndexDrop ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $datasetName ]
+ Parameter #2 [ <required> string $indexName ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsIndexGetAll ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsLinkConnect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsLinkDisconnect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsPendingMutationsGet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsLinkCreate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> array $analyticsLink ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsLinkReplace ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> array $analyticsLink ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsLinkDrop ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <required> string $linkName ]
+ Parameter #2 [ <required> string $dataverseName ]
+ Parameter #3 [ <optional> ?array $options = <default> ]
+ }
+ }
+ Function [ <internal:couchbase> function Couchbase\Extension\analyticsLinkGetAll ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $connection ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ }
}
- Classes [75] {
diff --git a/php-pecl-couchbase4.spec b/php-pecl-couchbase4.spec
index 45b707a..16cda4b 100644
--- a/php-pecl-couchbase4.spec
+++ b/php-pecl-couchbase4.spec
@@ -7,14 +7,11 @@
# Please, preserve the changelog entries
#
-# NOTICE: el-7 is not supported (cmake 3.19)
-# el-8 is not supported (cmake 3.20)
-# el-9 is not supported (cmake 3.20)
-# mock requires --enable-network
+# NOTICE: mock requires --enable-network
-# Disable RPATH check
-%global __arch_install_post /bin/true
-%global __brp_check_rpaths /bin/true
+# Disable RPATH check (no more needed)
+#global __arch_install_post /bin/true
+#global __brp_check_rpaths /bin/true
%{?scl:%scl_package php-pecl-couchbase4}
@@ -29,7 +26,7 @@
Summary: Couchbase Server PHP extension
Name: %{?scl_prefix}php-pecl-couchbase4
-Version: 4.2.1
+Version: 4.2.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Apache-2.0
# src
@@ -57,7 +54,7 @@ Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: git
BuildRequires: make
-BuildRequires: cmake >= 3.27
+BuildRequires: cmake >= 3.19
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel >= 8.1
@@ -170,6 +167,8 @@ mkdir ZTS
cd %{sources}
%{__phpize}
+# fix for make_install, notice make_build is broken
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
%configure --with-php-config=%{__phpconfig}
@@ -186,12 +185,12 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make install -C NTS INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install the ZTS stuff
%if %{with_zts}
-make install -C ZTS INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -231,6 +230,15 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%changelog
+* Wed Oct 23 2024 Remi Collet <remi@remirepo.net> - 4.2.4-1
+- update to 4.2.4
+
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 4.2.3-1
+- update to 4.2.3
+
+* Thu Jul 25 2024 Remi Collet <remi@remirepo.net> - 4.2.2-1
+- update to 4.2.2
+
* Wed Apr 24 2024 Remi Collet <remi@remirepo.net> - 4.2.1-1
- update to 4.2.1