summaryrefslogtreecommitdiffstats
path: root/makesrc.sh
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 07:34:45 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 07:34:45 +0200
commit5c7fd837b3a8e51eb4776a136828f96ea2a4a40e (patch)
tree09ec3c77dedbf9f24b4fee422e67f929e08c83a7 /makesrc.sh
parente4320af2e8c8adc99140a83f20c9f06628522f89 (diff)
update to 1.0.7
Diffstat (limited to 'makesrc.sh')
-rwxr-xr-xmakesrc.sh37
1 files changed, 0 insertions, 37 deletions
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index 87afb43..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
-TAG=$(sed -n '/^%global gh_tag/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
-
-if [ -f $NAME-$VERSION.tgz ]; then
- echo Skip $NAME-$VERSION.tgz
-else
- echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-
- echo "Cloning..."
- rm -rf $PROJECT-$VERSION
-
- if [ -z "$TAG" ]; then
- git clone --recursive https://github.com/$OWNER/$PROJECT.git $PROJECT-$VERSION
- pushd $PROJECT-$VERSION
- git checkout $COMMIT || exit 1
- popd
- else
- git clone --recursive --branch $TAG https://github.com/$OWNER/$PROJECT.git $PROJECT-$VERSION
- fi
-
- echo "Archiving..."
- tar czf $NAME-$VERSION.tgz --exclude .git $PROJECT-$VERSION
-
- echo "Cleaning..."
- rm -rf $PROJECT-$VERSION
-
- echo "Done."
-fi
-
-spectool -g -S *spec
-