summaryrefslogtreecommitdiffstats
path: root/php-pecl-apcu.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-apcu.spec')
-rw-r--r--php-pecl-apcu.spec23
1 files changed, 12 insertions, 11 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index d62c7d2..ccf1e90 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -29,10 +29,10 @@
Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
-Version: 5.1.23
+Version: 5.1.24
License: PHP-3.01
URL: https://pecl.php.net/package/APCu
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{pecl_name}-5.1.19.ini
Source2: %{pecl_name}-panel.conf
@@ -97,7 +97,7 @@ configuration, available on http://localhost/apcu-panel/
%prep
%setup -qc
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
# Sanity check, really often broken
@@ -127,19 +127,21 @@ sed -e '/"apc.php"/s/role="src"/role="doc"/' -i package.xml
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
--enable-apcu \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--enable-apcu \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
@@ -147,12 +149,12 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -187,10 +189,6 @@ done
%check
cd %{sources}
-if [ $(%{__php} -r 'echo PHP_VERSION_ID;') -ge 80400 ]; then
- rm tests/apc_entry_002.phpt
-fi
-
%{_bindir}/php -n \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
-m | grep '^apcu$'
@@ -252,6 +250,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Sep 23 2024 Remi Collet <remi@remirepo.net> - 5.1.24-1
+- update to 5.1.24
+
* Thu Jul 4 2024 Remi Collet <remi@remirepo.net> - 5.1.23-2
- skip 1 test with 8.4