summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-apcu.spec83
3 files changed, 30 insertions, 69 deletions
diff --git a/PHPINFO b/PHPINFO
index c4305d9..e97011d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,17 +2,17 @@
apcu
APCu Support => Enabled
-Version => 5.1.23
+Version => 5.1.24
APCu Debugging => Disabled
MMAP Support => Enabled
-MMAP File Mask => /tmp/apc.Ju2Kie
-Serialization Support => php, brotli, igbinary, lz4, snappy, zstd
-Build Date => Nov 12 2023 00:00:00
+MMAP File Mask => /tmp/apc.FQveSO
+Serialization Support => php, brotli, igbinary, lz4, msgpack, snappy, zstd
+Build Date => Sep 23 2024 00:00:00
Directive => Local Value => Master Value
apc.enabled => On => On
apc.shm_segments => 1 => 1
-apc.shm_size => 256M => 256M
+apc.shm_size => 32M => 32M
apc.entries_hint => 4096 => 4096
apc.gc_ttl => 3600 => 3600
apc.ttl => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 1c3f326..a8fe32d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #68 apcu version 5.1.23 ] {
+Extension [ <persistent> extension #64 apcu version 5.1.24 ] {
- INI {
Entry [ apc.enabled <SYSTEM> ]
@@ -8,7 +8,7 @@ Extension [ <persistent> extension #68 apcu version 5.1.23 ] {
Current = '1'
}
Entry [ apc.shm_size <SYSTEM> ]
- Current = '256M'
+ Current = '32M'
}
Entry [ apc.entries_hint <SYSTEM> ]
Current = '4096'
@@ -46,7 +46,7 @@ Extension [ <persistent> extension #68 apcu version 5.1.23 ] {
}
- Constants [16] {
- Constant [ int ] { 139777182917712 }
+ Constant [ int ] { 139993428940112 }
Constant [ int APC_LIST_ACTIVE ] { 1 }
Constant [ int APC_LIST_DELETED ] { 2 }
Constant [ int APC_ITER_TYPE ] { 1 }
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index 1791d39..0d4dc89 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-apcu
#
-# Copyright (c) 2013-2023 Remi Collet
+# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -29,10 +29,10 @@
Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
-Version: 5.1.23
+Version: 5.1.24
License: PHP-3.01
URL: https://pecl.php.net/package/APCu
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{pecl_name}-5.1.19.ini
Source2: %{pecl_name}-panel.conf
@@ -52,36 +52,6 @@ Provides: %{?scl_prefix}php-apcu%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(apcu) = %{version}
Provides: %{?scl_prefix}php-pecl(apcu)%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
APCu is userland caching: APC stripped of opcode caching.
@@ -127,7 +97,7 @@ configuration, available on http://localhost/apcu-panel/
%prep
%setup -qc
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
# Sanity check, really often broken
@@ -157,19 +127,21 @@ sed -e '/"apc.php"/s/role="src"/role="doc"/' -i package.xml
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
--enable-apcu \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--enable-apcu \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
@@ -177,12 +149,12 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{SOURCE1} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{SOURCE1} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -219,7 +191,7 @@ cd %{sources}
%{_bindir}/php -n \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- -m | grep 'apcu'
+ -m | grep '^apcu$'
%if %{with tests}
# Upstream test suite for NTS extension
@@ -232,7 +204,7 @@ REPORT_EXIT_STATUS=1 \
%if %{with_zts}
%{__ztsphp} -n \
-d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- -m | grep 'apcu'
+ -m | grep '^apcu$'
%if %{with tests}
# Upstream test suite for ZTS extension
@@ -244,28 +216,8 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -298,6 +250,15 @@ fi
%changelog
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 5.1.24-2
+- rebuild for 8.4.0RC1
+
+* Mon Sep 23 2024 Remi Collet <remi@remirepo.net> - 5.1.24-1
+- update to 5.1.24
+
+* Thu Jul 4 2024 Remi Collet <remi@remirepo.net> - 5.1.23-2
+- skip 1 test with 8.4
+
* Sun Nov 12 2023 Remi Collet <remi@remirepo.net> - 5.1.23-1
- update to 5.1.23