summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pear-PHP-CodeSniffer.spec25
1 files changed, 19 insertions, 6 deletions
diff --git a/php-pear-PHP-CodeSniffer.spec b/php-pear-PHP-CodeSniffer.spec
index cc6a837..4ccef5a 100644
--- a/php-pear-PHP-CodeSniffer.spec
+++ b/php-pear-PHP-CodeSniffer.spec
@@ -1,6 +1,6 @@
# spec file for php-pear-PHP-CodeSniffer
#
-# Copyright (c) 2013-2024 Remi Collet
+# Copyright (c) 2013-2025 Remi Collet
# Copyright (c) 2009-2013 Christof Damian
# Copyright (c) 2006-2009 Konstantin Ryabitsev
#
@@ -16,9 +16,9 @@
%bcond_without tests
-%global gh_commit 19473c30efe4f7b3cd42522d0b2e6e7f243c6f87
+%global gh_commit ba05f990e79cbe69b9f35c8c1ac8dca7eecc3a10
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-11-16
+%global gh_date 2025-01-23
%global gh_owner PHPCSStandards
%global gh_project PHP_CodeSniffer
# keep in old PEAR tree
@@ -26,7 +26,7 @@
Name: php-pear-PHP-CodeSniffer
-Version: 3.11.1
+Version: 3.11.3
Release: 1%{?dist}
Summary: PHP coding standards enforcement tool
@@ -48,6 +48,7 @@ BuildRequires: php-dom
BuildRequires: php-iconv
BuildRequires: php-intl
%if %{with tests}
+BuildRequires: php-bcmath
# to run test suite, from composer.json "require-dev"
# "phpunit/phpunit": "^4.0 || ^5.0 || ^6.0 || ^7.0 || ^8.0 || ^9.3.4"
%global phpunit %{_bindir}/phpunit9
@@ -111,15 +112,18 @@ rm src/Standards/Generic/Tests/Debug/JSHintUnitTest.*
# Fix current date
YEAR=$(date +%Y)
-sed -e "/@copyright/s/2021/${YEAR}/" \
+PREV=$(expr $YEAR - 1)
+sed -e "/@copyright/s/${PREV}/${YEAR}/" \
-i src/Standards/Squiz/Tests/Commenting/FileCommentUnitTest.1.*.fixed
-# Version 3.9.0: Tests: 2276, Assertions: 10969, Warnings: 4, Skipped: 12.
+# Version 3.11.2: Tests: 3174, Assertions: 18639, Warnings: 3, Skipped: 19.
+# testBrokenRulesetMultiError failing reported as https://github.com/PHPCSStandards/PHP_CodeSniffer/issues/767
ret=0
for cmdarg in "php %{phpunit}" php81 php82 php83 php84; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=-1 ${2:-%{_bindir}/phpunit9} \
+ --filter '^((?!(testBrokenRulesetMultiError)).)*$' \
|| ret=1
fi
done
@@ -144,6 +148,15 @@ fi
%changelog
+* Fri Jan 24 2025 Remi Collet <remi@remirepo.net> - 3.11.3-1
+- update to 3.11.3
+
+* Wed Jan 22 2025 Remi Collet <remi@remirepo.net> - 3.11.2-2
+- fix tests failing because of new year
+
+* Thu Dec 12 2024 Remi Collet <remi@remirepo.net> - 3.11.2-1
+- update to 3.11.2
+
* Mon Nov 18 2024 Remi Collet <remi@remirepo.net> - 3.11.1-1
- update to 3.11.1