summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-mock2.spec36
1 files changed, 14 insertions, 22 deletions
diff --git a/php-mock2.spec b/php-mock2.spec
index e297023..61f24c0 100644
--- a/php-mock2.spec
+++ b/php-mock2.spec
@@ -1,21 +1,21 @@
# remirepo/fedora spec file for php-mock2
#
-# Copyright (c) 2016-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2016-2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%global gh_commit fff1a621ebe54100fa3bd852e7be57773a0c0127
+%global gh_commit 8f58972dce4de5a804dc0459383a11bc651416cf
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-02-10
+%global gh_date 2024-12-09
%global gh_owner php-mock
%global gh_project php-mock
%global with_tests 0%{!?_without_tests:1}
%global major 2
Name: php-mock%{major}
-Version: 2.5.0
+Version: 2.5.1
Release: 1%{?dist}
Summary: PHP-Mock can mock built-in PHP functions
@@ -42,26 +42,16 @@ BuildRequires: php-composer(fedora/autoloader)
# "php": "^5.6 || ^7.0 || ^8.0",
# "phpunit/php-text-template": "^1 || ^2 || ^3 || ^4")
Requires: php(language) >= 5.6
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpunit/php-text-template) >= 1 with php-composer(phpunit/php-text-template) < 5)
-# remirepo:3
-%else
-Requires: php-phpunit-Text-Template
-%endif
# From phpcompatinfo report from version 2.0.0
Requires: php-date
Requires: php-reflection
Requires: php-spl
# For autoloader
Requires: php-composer(fedora/autoloader)
-# remirepo:1
-%if 0%{?fedora} > 21 || 0%{?rhel} >= 8
# from composer.json, "suggest": {
# "php-mock/php-mock-phpunit": "Allows integration into PHPUnit testcase with the trait PHPMock."
Suggests: php-composer(php-mock/php-mock-phpunit)
-# remirepo:1
-%endif
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
@@ -146,7 +136,7 @@ if [ -x %{_bindir}/phpunit8 ]; then
fi
if [ -x %{_bindir}/phpunit9 ]; then
- for cmd in php php80 php81 php82 php83;do
+ for cmd in php php80 php81 php82 php83 php84;do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--filter '^((?!(testDefiningAfterCallingUnqualified|testEnable)).)*$' \
@@ -156,7 +146,7 @@ if [ -x %{_bindir}/phpunit9 ]; then
fi
if [ -x %{_bindir}/phpunit10 ]; then
- for cmd in php php81 php82 php83;do
+ for cmd in php php81 php82 php83 php84;do
if which $cmd; then
$cmd %{_bindir}/phpunit10 \
--filter '^((?!(testDefiningAfterCallingUnqualified|testEnable)).)*$' \
@@ -166,7 +156,7 @@ if [ -x %{_bindir}/phpunit10 ]; then
fi
if [ -x %{_bindir}/phpunit11 ]; then
- for cmd in php php82 php83;do
+ for cmd in php php82 php83 php84;do
if which $cmd; then
$cmd %{_bindir}/phpunit11 \
--filter '^((?!(testDefiningAfterCallingUnqualified|testEnable)).)*$' \
@@ -181,8 +171,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc *.md
@@ -191,9 +179,13 @@ exit $ret
%changelog
+* Mon Dec 9 2024 Remi Collet <remi@remirepo.net> - 2.5.1-1
+- update to 2.5.1
+- re-license spec file to CECILL-2.1
+
* Mon Feb 12 2024 Remi Collet <remi@remirepo.net> - 2.5.0-1
- update to 2.5.0
-- allow phpunit10
+- allow phpunit11
* Tue Jun 13 2023 Remi Collet <remi@remirepo.net> - 2.4.1-1
- update to 2.4.1 (no change)