summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-14 07:29:36 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-14 07:29:36 +0200
commit530dccc8392815c4e9f9e3dfd265860eaaee7c5a (patch)
tree8691f232feb3da7236b4253b83f493801df00679
parentf09669fd0bbc0e83cfc194cbc726a1fe7967622e (diff)
php-horde-horde-lz4: 1.0.8
-rw-r--r--horde_lz4-php7.patch57
-rw-r--r--php-horde-horde-lz4.spec12
2 files changed, 5 insertions, 64 deletions
diff --git a/horde_lz4-php7.patch b/horde_lz4-php7.patch
deleted file mode 100644
index 2fc4d5f..0000000
--- a/horde_lz4-php7.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From d2f0184e58d6d05569624bc52d2be76c65a9d297 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 30 Mar 2015 19:00:17 +0200
-Subject: [PATCH] Fix PHP 7 compatibility
-
----
- framework/lz4/horde_lz4.c | 6 +++---
- framework/lz4/horde_lz4.h | 7 +++++++
- 2 files changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/framework/lz4/horde_lz4.c b/framework/lz4/horde_lz4.c
-index 28ec47f..23625be 100644
---- a/framework/lz4/horde_lz4.c
-+++ b/framework/lz4/horde_lz4.c
-@@ -87,7 +87,7 @@ PHP_FUNCTION(horde_lz4_compress)
- RETURN_FALSE;
- }
-
-- data_len = Z_STRLEN_P(data);
-+ data_len = (int)Z_STRLEN_P(data);
-
- output = (char *)emalloc(LZ4_compressBound(data_len) + header_offset);
- if (!output) {
-@@ -107,7 +107,7 @@ PHP_FUNCTION(horde_lz4_compress)
- if (output_len <= 0) {
- RETVAL_FALSE;
- } else {
-- RETVAL_STRINGL(output, output_len + header_offset, 1);
-+ HORDE_LZ4_RETSTRL(output, output_len + header_offset);
- }
-
- efree(output);
-@@ -155,7 +155,7 @@ PHP_FUNCTION(horde_lz4_uncompress)
- if (output_len <= 0) {
- RETVAL_FALSE;
- } else {
-- RETVAL_STRINGL(output, data_len, 1);
-+ HORDE_LZ4_RETSTRL(output, data_len);
- }
-
- efree(output);
-diff --git a/framework/lz4/horde_lz4.h b/framework/lz4/horde_lz4.h
-index eb4e7a5..8ff3f7c 100644
---- a/framework/lz4/horde_lz4.h
-+++ b/framework/lz4/horde_lz4.h
-@@ -23,4 +23,11 @@ PHP_MINFO_FUNCTION(horde_lz4);
- PHP_FUNCTION(horde_lz4_compress);
- PHP_FUNCTION(horde_lz4_uncompress);
-
-+#if PHP_MAJOR_VERSION < 7
-+#define HORDE_LZ4_RETSTRL(a,l) RETURN_STRINGL(a,l,1)
-+#else
-+typedef size_t strsize;
-+#define HORDE_LZ4_RETSTRL(a,l) RETURN_STRINGL(a,l)
-+#endif
-+
- #endif /* PHP_HORDE_LZ4_H */
diff --git a/php-horde-horde-lz4.spec b/php-horde-horde-lz4.spec
index c1f7a94..b75610d 100644
--- a/php-horde-horde-lz4.spec
+++ b/php-horde-horde-lz4.spec
@@ -28,16 +28,13 @@
Summary: Horde LZ4 Compression Extension
Name: %{?scl_prefix}php-horde-horde-lz4
-Version: 1.0.7
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.0.8
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
URL: http://www.horde.org
Source0: http://%{pecl_channel}/get/%{pecl_name}-%{version}.tgz
-# https://github.com/horde/horde/pull/132
-Patch0: %{pecl_name}-php7.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -103,8 +100,6 @@ cd NTS
# Use system library
rm -r lib
-%patch0 -p3 -b .php7
-
# Sanity check, really often broken
extver=$(sed -n '/#define HORDE_LZ4_EXT_VERSION/{s/.* "//;s/".*$//;p}' horde_lz4.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -229,6 +224,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Apr 14 2015 Remi Collet <remi@fedoraproject.org> - 1.0.8-1
+- Update to 1.0.8
+
* Mon Mar 30 2015 Remi Collet <remi@fedoraproject.org> 1.0.7-2
- add fix for PHP 7
- drop runtime dependency on pear, new scriptlets