summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-dasprid-enum.spec19
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 133e279..a099aba 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"php": ">=7.1 <9.0"
},
"require-dev": {
- "phpunit/phpunit": "^7 | ^8 | ^9",
+ "phpunit/phpunit": "^7 || ^8 || ^9 || ^10 || ^11",
"squizlabs/php_codesniffer": "*"
},
"autoload": {
diff --git a/php-dasprid-enum.spec b/php-dasprid-enum.spec
index 1b88a45..473f198 100644
--- a/php-dasprid-enum.spec
+++ b/php-dasprid-enum.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-dasprid-enum
#
-# Copyright (c) 2019-2023 Remi Collet
+# Copyright (c) 2019-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit 6faf451159fb8ba4126b925ed2d78acfce0dc016
+%global gh_commit 8dfd07c6d2cf31c8da90c53b83c026c7696dda90
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner DASPRiD
%global gh_project Enum
@@ -22,7 +22,7 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.5
+Version: 1.0.6
Release: 1%{?dist}
Summary: PHP enum implementation
@@ -39,9 +39,9 @@ BuildRequires: php(language)
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^7 | ^8 | ^9",
+# "phpunit/phpunit": "^7 || ^8 || ^9 || ^10 || ^11",
# "squizlabs/php_codesniffer": "^3.4"
-%global phpunit %{_bindir}/phpunit9
+%global phpunit %{_bindir}/phpunit10
BuildRequires: %{phpunit}
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -100,10 +100,10 @@ require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
ret=0
-for cmd in "php %{phpunit}" php80 php81 php82 php83; do
+for cmd in "php %{phpunit}" php81 php82 php83 "php84 %{_bindir}/phpunit11"; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} || ret=1
fi
done
exit $ret
@@ -113,7 +113,6 @@ exit $ret
%files
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc README.md
@@ -122,6 +121,10 @@ exit $ret
%changelog
+* Mon Aug 12 2024 Remi Collet <remi@remirepo.net> - 1.0.6-1
+- update to 1.0.6 (no change)
+- switch to phpunit10
+
* Tue Aug 29 2023 Remi Collet <remi@remirepo.net> - 1.0.5-1
- update to 1.0.5 (no change)
- sources from git snapshot