summaryrefslogtreecommitdiffstats
path: root/mysql-home.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-02-07 19:35:09 +0100
committerRemi Collet <fedora@famillecollet.com>2011-02-07 19:35:09 +0100
commit42f6b501f74be018842a560a4a1daad888a4d12f (patch)
tree43dd31061fafc83e40730349c5d5563a0cd0004e /mysql-home.patch
parente04b6e74d7f6b494fc235e1a81937370e54834e9 (diff)
mysql 5.5.8, sync with rawhide (latest patches)
Diffstat (limited to 'mysql-home.patch')
-rw-r--r--mysql-home.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/mysql-home.patch b/mysql-home.patch
new file mode 100644
index 0000000..054d389
--- /dev/null
+++ b/mysql-home.patch
@@ -0,0 +1,16 @@
+mysql 5.5's new cmake-based build scripts forgot about defining
+DEFAULT_HOME_ENV. Upstream at http://bugs.mysql.com/bug.php?id=59280
+
+
+diff -Naur mysql-5.5.8.orig/mysys/CMakeLists.txt mysql-5.5.8/mysys/CMakeLists.txt
+--- mysql-5.5.8.orig/mysys/CMakeLists.txt 2010-12-03 12:58:26.000000000 -0500
++++ mysql-5.5.8/mysys/CMakeLists.txt 2011-01-13 11:58:42.583471734 -0500
+@@ -69,6 +69,8 @@
+ SET(MYSYS_SOURCES ${MYSYS_SOURCES} my_port.c)
+ ENDIF()
+
++ADD_DEFINITIONS( -DDEFAULT_HOME_ENV=MYSQL_HOME)
++
+ ADD_CONVENIENCE_LIBRARY(mysys ${MYSYS_SOURCES})
+ TARGET_LINK_LIBRARIES(mysys dbug strings ${ZLIB_LIBRARY}
+ ${LIBNSL} ${LIBM} ${LIBRT})