summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-08 18:44:01 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-08 18:44:01 +0100
commit632485efde2e832d66ae4fa08e58d042e67ee1b3 (patch)
tree97c5f677d0aa7dc46730725379219a89aa1bbba0
parent1bc3913ad6c6bf3ebe2f8598af93c3485e1e98d4 (diff)
Xulrunner 18.0 (not ready)
-rw-r--r--mozilla-746112.patch86
-rw-r--r--xulrunner.spec28
2 files changed, 17 insertions, 97 deletions
diff --git a/mozilla-746112.patch b/mozilla-746112.patch
deleted file mode 100644
index 01f6e16..0000000
--- a/mozilla-746112.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-diff -up xulrunner-17.0/mozilla-beta/js/src/gc/Heap.h.746112 xulrunner-17.0/mozilla-beta/js/src/gc/Heap.h
---- xulrunner-17.0/mozilla-beta/js/src/gc/Heap.h.746112 2012-10-17 16:32:43.000000000 +0200
-+++ xulrunner-17.0/mozilla-beta/js/src/gc/Heap.h 2012-10-24 14:48:12.186640489 +0200
-@@ -103,26 +103,31 @@ struct Cell
- };
-
- /*
-- * Page size is 4096 by default, except for SPARC, where it is 8192.
-+ * Page size must be static to support our arena pointer optimizations, so we
-+ * are forced to support each platform with non-4096 pages as a special case.
-+ * Note: The freelist supports a maximum arena shift of 15.
- * Note: Do not use JS_CPU_SPARC here, this header is used outside JS.
- * Bug 692267: Move page size definition to gc/Memory.h and include it
- * directly once jsgc.h is no longer an installed header.
- */
- #if defined(SOLARIS) && (defined(__sparc) || defined(__sparcv9))
- const size_t PageShift = 13;
-+const size_t ArenaShift = PageShift;
-+#elif defined(__powerpc__)
-+const size_t PageShift = 16;
-+const size_t ArenaShift = 12;
- #else
- const size_t PageShift = 12;
-+const size_t ArenaShift = PageShift;
- #endif
- const size_t PageSize = size_t(1) << PageShift;
-+const size_t ArenaSize = size_t(1) << ArenaShift;
-+const size_t ArenaMask = ArenaSize - 1;
-
- const size_t ChunkShift = 20;
- const size_t ChunkSize = size_t(1) << ChunkShift;
- const size_t ChunkMask = ChunkSize - 1;
-
--const size_t ArenaShift = PageShift;
--const size_t ArenaSize = PageSize;
--const size_t ArenaMask = ArenaSize - 1;
--
- /*
- * This is the maximum number of arenas we allow in the FreeCommitted state
- * before we trigger a GC_SHRINK to release free arenas to the OS.
-diff -up xulrunner-17.0/mozilla-beta/js/src/jsgc.cpp.746112 xulrunner-17.0/mozilla-beta/js/src/jsgc.cpp
---- xulrunner-17.0/mozilla-beta/js/src/jsgc.cpp.746112 2012-10-17 16:32:44.000000000 +0200
-+++ xulrunner-17.0/mozilla-beta/js/src/jsgc.cpp 2012-10-24 14:46:28.253638095 +0200
-@@ -251,6 +251,13 @@ static const int BackgroundPhaseLength[]
- sizeof(BackgroundPhaseStrings) / sizeof(AllocKind)
- };
-
-+/* Unused memory decommiting requires the arena size match the page size. */
-+static bool
-+DecommitEnabled()
-+{
-+ return PageSize == ArenaSize;
-+}
-+
- #ifdef DEBUG
- void
- ArenaHeader::checkSynchronizedWithFreeList() const
-@@ -742,7 +749,8 @@ Chunk::fetchNextDecommittedArena()
- decommittedArenas.unset(offset);
-
- Arena *arena = &arenas[offset];
-- MarkPagesInUse(arena, ArenaSize);
-+ if (DecommitEnabled())
-+ MarkPagesInUse(arena, ArenaSize);
- arena->aheader.setAsNotAllocated();
-
- return &arena->aheader;
-@@ -2731,7 +2739,7 @@ DecommitArenasFromAvailableList(JSRuntim
- chunk->removeFromAvailableList();
-
- size_t arenaIndex = Chunk::arenaIndex(aheader->arenaAddress());
-- bool ok;
-+ bool ok = true;
- {
- /*
- * If the main thread waits for the decommit to finish, skip
-@@ -2741,7 +2749,8 @@ DecommitArenasFromAvailableList(JSRuntim
- Maybe<AutoUnlockGC> maybeUnlock;
- if (!rt->isHeapBusy())
- maybeUnlock.construct(rt);
-- ok = MarkPagesUnused(aheader->getArena(), ArenaSize);
-+ if (DecommitEnabled())
-+ ok = MarkPagesUnused(aheader->getArena(), ArenaSize);
- }
-
- if (ok) {
diff --git a/xulrunner.spec b/xulrunner.spec
index 8f10136..e8f5993 100644
--- a/xulrunner.spec
+++ b/xulrunner.spec
@@ -1,5 +1,5 @@
# Use system nspr/nss?
-%if 0%{?fedora} < 16 && 0%{?rhel} < 7
+%if 0%{?fedora} < 18 && 0%{?rhel} < 7
%define system_nss 0
%else
%define system_nss 1
@@ -33,9 +33,9 @@
%global libvpx_version 1.0.0
%if %{?system_nss}
-%global nspr_version 4.9.2
+%global nspr_version 4.9.3
%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
-%global nss_version 3.13.5
+%global nss_version 3.14.1
%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
%endif
@@ -82,7 +82,7 @@
Summary: XUL Runtime for Gecko Applications
Name: %{shortname}-last
-Version: 17.0.1
+Version: 18.0
Release: 1%{?pre_tag}%{?dist}
URL: http://developer.mozilla.org/En/XULRunner
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -107,7 +107,6 @@ Patch18: xulrunner-16.0-jemalloc-ppc.patch
Patch20: mozilla-193-pkgconfig.patch
# Upstream patches
-Patch49: mozilla-746112.patch
# ---------------------------------------------------
@@ -253,8 +252,6 @@ cd %{tarballdir}
%patch20 -p2 -b .pk
-%patch49 -p2 -b .746112
-
%{__rm} -f .mozconfig
%{__cat} %{SOURCE10} \
%if ! %{system_vpx}
@@ -324,7 +321,7 @@ echo "ac_add_options --disable-polyic" >> .mozconfig
echo "ac_add_options --disable-tracejit" >> .mozconfig
%endif
-%ifnarch %{ix86} x86_64 %{arm}
+%ifnarch %{ix86} x86_64
echo "ac_add_options --disable-webrtc" >> .mozconfig
%endif
@@ -351,8 +348,7 @@ cd %{tarballdir}
#
# Disable C++ exceptions since Mozilla code is not exception-safe
#
-MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
- %{__sed} -e 's/-Wall//')
+MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS" | %{__sed} -e 's/-Wall//')
%if %{?debug_build}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-O2//')
%endif
@@ -364,7 +360,7 @@ MOZ_LINK_FLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
%endif
export CFLAGS=$MOZ_OPT_FLAGS
-export CXXFLAGS=$MOZ_OPT_FLAGS
+export CXXFLAGS="$MOZ_OPT_FLAGS -fpermissive"
export LDFLAGS=$MOZ_LINK_FLAGS
export PREFIX='%{_prefix}'
@@ -549,6 +545,16 @@ fi
#---------------------------------------------------------------------
%changelog
+* Tue Jan 8 2013 Remi Collet <RPMS@FamilleCollet.com> - 18.0-1
+- Sync with rawhide, Update to 18.0
+
+* Mon Jan 7 2013 Martin Stransky <stransky@redhat.com> - 18.0-1
+- Update to 18.0
+
+* Thu Dec 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> 17.0.1-3
+- Disable webrtc on ARM as it currently tries to build SSE on ARM (fix FTBFS)
+- Enable methodjit/tracejit on ARMv7 for more speed :) Fixes RHBZ 870548
+
* Thu Nov 29 2012 Remi Collet <RPMS@FamilleCollet.com> - 17.0-1
- Sync with rawhide, Update to 17.0.1