summaryrefslogtreecommitdiffstats
path: root/libhandlebars.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libhandlebars.spec')
-rw-r--r--libhandlebars.spec25
1 files changed, 11 insertions, 14 deletions
diff --git a/libhandlebars.spec b/libhandlebars.spec
index 726b83d..a4387b7 100644
--- a/libhandlebars.spec
+++ b/libhandlebars.spec
@@ -7,12 +7,7 @@
# Please, preserve the changelog entries
#
-%if 0%{?rhel} == 7
-# disabe test suite as check version is too old
-%bcond_with tests
-%else
%bcond_without tests
-%endif
%global soname 9
@@ -34,7 +29,7 @@
Name: %{libname}
Version: 1.0.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Handlebars C library
# SPDX
@@ -46,6 +41,9 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_
Source1: https://github.com/%{hspec_owner}/%{hspec_project}/archive/%{hspec_commit}/%{hspec_project}-%{hspec_short}.tar.gz
Source2: https://github.com/%{mspec_owner}/%{mspec_project}/archive/%{mspec_commit}/%{mspec_project}-%{mspec_short}.tar.gz
+# Use pcre2 instead of pcre
+Patch0: pcre2.patch
+
BuildRequires: gcc
BuildRequires: autoconf
BuildRequires: automake
@@ -53,7 +51,7 @@ BuildRequires: libtool
BuildRequires: libyaml-devel
BuildRequires: json-c-devel
BuildRequires: libtalloc-devel
-BuildRequires: pcre-devel
+BuildRequires: pcre2-devel
BuildRequires: lmdb-devel
%if %{with tests}
BuildRequires: check-devel >= 0.12
@@ -97,6 +95,8 @@ This package provides handlebarsc command line tool split off %{libname}.
%prep
%setup -qn %{gh_project}-%{gh_commit} -a1 -a2
+%patch -P0 -p1 -b .pcre2
+
mkdir spec
mv %{hspec_project}-%{hspec_commit} spec/handlebars
mv %{mspec_project}-%{mspec_commit} spec/mustache
@@ -124,14 +124,7 @@ make test
%endif
-%if 0%{?fedora} < 28 && 0%{?rhel} < 8
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-%endif
-
-
%files
-%{!?_licensedir:%global license %%doc}
%license LICENSE*
%{_libdir}/%{libname}.so.%{soname}*
@@ -146,6 +139,10 @@ make test
%changelog
+* Fri Nov 29 2024 Remi Collet <remi@remirepo.net> - 1.0.0-2
+- use pcre2 instead of pcre using patch from
+ https://github.com/jbboehr/handlebars.c/pull/99
+
* Mon Nov 28 2022 Remi Collet <remi@remirepo.net> - 1.0.0-1
- update to 1.0.0
- soname bump