summaryrefslogtreecommitdiffstats
path: root/judy1php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'judy1php.spec')
-rw-r--r--judy1php.spec41
1 files changed, 34 insertions, 7 deletions
diff --git a/judy1php.spec b/judy1php.spec
index f0e1b5a..0681805 100644
--- a/judy1php.spec
+++ b/judy1php.spec
@@ -1,6 +1,20 @@
-Name: Judy
+# remirepo spec file for judy1php
+# renamed for parallel installation, from:
+#
+# Fedora spec file for Judy
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+%global libname Judy
+%global oldsoname 1
+%global newsoname 1
+
+Name: judy%{oldsoname}php
Version: 1.0.5
-Release: 18%{?dist}
+Release: 20%{?dist}
Summary: General purpose dynamic array
License: LGPLv2+
URL: http://sourceforge.net/projects/judy/
@@ -31,10 +45,16 @@ Judy is designed as an unbounded array, the size of a Judy array is
not pre-allocated but grows and shrinks dynamically with the array
population.
+%{name} is designed to be installed beside %{libname}
+and only used by PHP extensions (memprof...).
+
%package devel
Summary: Development libraries and headers for Judy
Requires: %{name} = %{version}-%{release}
+Conflicts: %{libname}-devel < %{version}-%{release}
+Provides: %{libname}-devel = %{version}-%{release}
+
%description devel
This package contains the development libraries and header files
for developing applications that use the Judy library.
@@ -46,6 +66,11 @@ for developing applications that use the Judy library.
%patch2 -p1 -b .behavior
cp -p %{SOURCE1} .
+: bump soname
+grep 'VERSION_INFO' configure.ac
+sed -e '/^VERSION_INFO/s/1:3:0/101:3:0/' -i configure
+
+
%build
export CFLAGS="%{optflags} -fno-strict-aliasing -fno-tree-ccp -fno-tree-dominator-opts -fno-tree-copy-prop -fno-tree-vrp"
%configure --disable-static
@@ -76,13 +101,10 @@ cd -
%endif
%files
-%if 0%{?_licensedir:1}
+%{!?_licensedir:%global license %%doc}
%license COPYING README.Fedora
-%else
-%doc COPYING README.Fedora
-%endif
%doc AUTHORS ChangeLog README examples/
-%{_libdir}/libJudy.so.*
+%{_libdir}/libJudy.so.%{newsoname}*
%files devel
%doc doc
@@ -90,7 +112,12 @@ cd -
%{_libdir}/libJudy.so
%{_mandir}/man3/J*.3*
+
%changelog
+* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- rename to judy1php
+- bump soname to 101
+
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.5-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild