summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--icu-last.spec24
-rw-r--r--python313-unittest.patch23
2 files changed, 32 insertions, 15 deletions
diff --git a/icu-last.spec b/icu-last.spec
index f2a2174..0b11461 100644
--- a/icu-last.spec
+++ b/icu-last.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for icu73
+# remirepo spec file for icu74
# renamed for parallel installation, from:
#
# Fedora spec file for icu
@@ -10,7 +10,7 @@
#
%global srcname icu
-%global soname 73
+%global soname 74
%global subver 2
%bcond_without tests
@@ -19,7 +19,7 @@
# (or update the timezone data update..).
%global use_tzdata_update 0
# Adjust to version major; used in tzdata update.
-%global icu_major 73
+%global icu_major 74
%if 0%{?fedora} == 34 || 0%{?rhel} == 9
# rhbz#2003359 crash in umtx_initImplPreInit() from unorm_normalize()
@@ -43,13 +43,8 @@ Source5: https://raw.githubusercontent.com/unicode-org/icu-data/main/tzdata/ic
Source10: icu-config.sh
BuildRequires: doxygen, autoconf >= 2.69, python3
-%if 0%{?rhel} == 7
-%global dtsenable source /opt/rh/devtoolset-10/enable
-BuildRequires: devtoolset-10-toolchain
-%else
BuildRequires: gcc
BuildRequires: gcc-c++
-%endif
BuildRequires: make
Requires: lib%{name}%{?_isa} = %{version}-%{release}
@@ -62,6 +57,8 @@ Provides: %{srcname}%{?_isa} = %{version}-%{release}
Patch4: gennorm2-man.patch
Patch5: icuinfo-man.patch
+# https://github.com/unicode-org/icu/pull/3046
+Patch6: python313-unittest.patch
%description
Tools and utilities for developing with icu.
@@ -114,6 +111,7 @@ Provides: lib%{srcname}-doc = %{version}-%{release}
%setup -q -n %{srcname}
%patch -P4 -p1 -b .gennorm2-man.patch
%patch -P5 -p1 -b .icuinfo-man.patch
+%patch -P6 -p1 -b .python313
%if 1
sed -e '/SELFCHECK=1/d' -i source/Makefile.in
@@ -197,13 +195,6 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
%endif
-%if 0%{?fedora} < 28 && 0%{?rhel} < 8
-%post -n lib%{name} -p /sbin/ldconfig
-%postun -n lib%{name} -p /sbin/ldconfig
-%endif
-
-%{!?_licensedir:%global license %%doc}
-
%files
%license license.html
%exclude %{_datadir}/%{srcname}/*/LICENSE
@@ -259,6 +250,9 @@ LD_LIBRARY_PATH=lib:stubdata:tools/ctestfw:$LD_LIBRARY_PATH bin/uconv -l
%changelog
+* Thu Aug 29 2024 Remi Collet <remi@remirepo.net> - 74.2-1
+- update to 74.2 (from F40)
+
* Mon Oct 30 2023 Remi Collet <remi@remirepo.net> - 73.2-1
- update to 73.2 (from F39)
diff --git a/python313-unittest.patch b/python313-unittest.patch
new file mode 100644
index 0000000..176a39b
--- /dev/null
+++ b/python313-unittest.patch
@@ -0,0 +1,23 @@
+From 2afa94a7dca53d1a7ed8d1f77823173e33d92202 Mon Sep 17 00:00:00 2001
+From: Yaakov Selkowitz <yselkowi@redhat.com>
+Date: Fri, 21 Jun 2024 14:48:56 -0400
+Subject: [PATCH] Update filtration_test for Python 3.13
+
+`unittest.makeSuite()` was deprecated in Python 3.11 and removed in 3.13:
+
+https://docs.python.org/3.13/whatsnew/3.13.html#unittest
+---
+
+ source/python/icutools/databuilder/test/filtration_test.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/source/python/icutools/databuilder/test/filtration_test.py b/source/python/icutools/databuilder/test/filtration_test.py
+index 416223bd7e34..41b593715d50 100644
+--- a/source/python/icutools/databuilder/test/filtration_test.py
++++ b/source/python/icutools/databuilder/test/filtration_test.py
+@@ -418,4 +418,4 @@ def _check_filter(self, filter, expected_matches, tree="locales"):
+ self.assertEqual(is_match, expected_match, file_stem)
+
+ # Export the test for the runner
+-suite = unittest.makeSuite(FiltrationTest)
++suite = unittest.defaultTestLoader.loadTestsFromTestCase(FiltrationTest)