summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--enchant2.spec153
-rw-r--r--enchant_aspell.patch29
4 files changed, 195 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/enchant2.spec b/enchant2.spec
new file mode 100644
index 0000000..2f151fc
--- /dev/null
+++ b/enchant2.spec
@@ -0,0 +1,153 @@
+Name: enchant2
+Version: 2.2.8
+Release: 1%{?snap}%{?dist}
+Summary: An Enchanting Spell Checking Library
+
+License: LGPLv2+
+URL: https://github.com/AbiWord/enchant
+Source0: https://github.com/AbiWord/enchant/releases/download/v%{version}/enchant-%{version}.tar.gz
+
+# Look for aspell using pkg-config, instead of AC_CHECK_LIB which adds -laspell
+# to the global LIBS and over-links libenchant (#1574893)
+Patch0: enchant_aspell.patch
+
+BuildRequires: automake autoconf libtool
+
+BuildRequires: gcc-c++
+BuildRequires: glib2-devel
+BuildRequires: aspell-devel
+BuildRequires: hunspell-devel
+BuildRequires: libvoikko-devel
+
+Provides: bundled(gnulib)
+
+
+%description
+A library that wraps other spell checking backends.
+
+
+%package aspell
+Summary: Integration with aspell for libenchant
+Requires: enchant2%{?_isa} = %{version}-%{release}
+
+%description aspell
+Libraries necessary to integrate applications using libenchant with aspell.
+
+%package voikko
+Summary: Integration with voikko for libenchant
+Requires: enchant2%{?_isa} = %{version}-%{release}
+Supplements: (enchant2 and langpacks-fi)
+
+%description voikko
+Libraries necessary to integrate applications using libenchant with voikko.
+
+
+%package devel
+Summary: Development files for %{name}
+Requires: enchant2%{?_isa} = %{version}-%{release}
+Requires: glib2-devel
+
+%description devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
+
+%prep
+%autosetup -p1 -n enchant-%{version}
+
+# Needed for Patch0
+autoreconf -ifv
+
+
+%build
+%configure \
+ --with-aspell \
+ --with-hunspell-dir=%{_datadir}/myspell \
+ --without-hspell \
+ --disable-static
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g;
+ s|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+%make_build pkgdatadir=%{_datadir}/enchant-2
+
+
+%install
+%make_install pkgdatadir=%{_datadir}/enchant-2
+find %{buildroot} -name '*.la' -delete
+
+
+%ldconfig_scriptlets
+
+
+%files
+%doc AUTHORS NEWS README
+%license COPYING.LIB
+%{_bindir}/enchant-2
+%{_bindir}/enchant-lsmod-2
+%{_libdir}/libenchant-2.so.*
+%dir %{_libdir}/enchant-2
+%{_libdir}/enchant-2/enchant_hunspell.so
+%{_mandir}/man1/*
+%{_datadir}/enchant-2
+
+%files aspell
+%{_libdir}/enchant-2/enchant_aspell.so*
+
+%files voikko
+%{_libdir}/enchant-2/enchant_voikko.so*
+
+%files devel
+%{_libdir}/libenchant-2.so
+%{_libdir}/pkgconfig/enchant-2.pc
+%{_includedir}/enchant-2
+
+
+%changelog
+* Mon Mar 02 2020 Sandro Mani <manisandro@gmail.com> - 2.2.8-1
+- Update to 2.2.8
+
+* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.7-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Sun Sep 15 2019 Sandro Mani <manisandro@gmail.com> - 2.2.7-1
+- Update to 2.2.7
+
+* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 2.2.5-1
+- Update to 2.2.5
+
+* Fri Jun 28 2019 Sandro Mani <manisandro@gmail.com> - 2.2.4-2
+- Add patch to fix memory leaks (#1718084)
+- Pass --without-hspell
+
+* Tue Jun 18 2019 Sandro Mani <manisandro@gmail.com> - 2.2.4-1
+- Update to 2.2.4
+
+* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.3-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.3-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Fri Jun 15 2018 Sandro Mani <manisandro@gmail.com> - 2.2.3-4
+- Add patch to avoid unnecessary linking of libenchant against libaspell (#1574893)
+
+* Wed May 16 2018 Parag Nemade <pnemade AT redhat DOT com> - 2.2.3-3
+- Make enchant2-voikko installed by langpacks-fi package (#1578352)
+
+* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Mon Feb 05 2018 Sandro Mani <manisandro@gmail.com> - 2.2.3-1
+- Update to 2.2.3
+
+* Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
+- Update to 2.2.1
+
+* Thu Dec 14 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-2
+- Add patch to fix FSF addresses
+- Kill rpath
+
+* Wed Dec 13 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-1
+- Initial package
diff --git a/enchant_aspell.patch b/enchant_aspell.patch
new file mode 100644
index 0000000..7d224fc
--- /dev/null
+++ b/enchant_aspell.patch
@@ -0,0 +1,29 @@
+diff -rupN --no-dereference enchant-2.2.8/configure.ac enchant-2.2.8-new/configure.ac
+--- enchant-2.2.8/configure.ac 2020-02-27 16:32:32.000000000 +0100
++++ enchant-2.2.8-new/configure.ac 2020-03-02 10:54:46.624164372 +0100
+@@ -212,7 +212,7 @@ build_providers=
+ dnl Standard providers
+ ENCHANT_CHECK_PKG_CONFIG_PROVIDER([hunspell], [HUNSPELL])
+ ENCHANT_CHECK_PKG_CONFIG_PROVIDER([nuspell], [NUSPELL])
+-ENCHANT_CHECK_LIB_PROVIDER([aspell], [ASPELL], [get_aspell_dict_info_list])
++ENCHANT_CHECK_PKG_CONFIG_PROVIDER([aspell], [ASPELL])
+ ENCHANT_CHECK_LIB_PROVIDER([hspell], [HSPELL], [hspell_get_dictionary_path],, [-lz])
+ ENCHANT_CHECK_PKG_CONFIG_PROVIDER([voikko], [VOIKKO], [libvoikko])
+ dnl FIXME: The test below assumes GCC(-compatible) ObjC++ compiler, but
+diff -rupN --no-dereference enchant-2.2.8/providers/Makefile.am enchant-2.2.8-new/providers/Makefile.am
+--- enchant-2.2.8/providers/Makefile.am 2020-02-27 14:05:18.000000000 +0100
++++ enchant-2.2.8-new/providers/Makefile.am 2020-03-02 10:54:46.624164372 +0100
+@@ -12,6 +12,7 @@ AM_LDFLAGS = -module -avoid-version -no-
+ if WITH_ASPELL
+ provider_LTLIBRARIES += enchant_aspell.la
+ endif
++enchant_aspell_la_LIBADD = $(ASPELL_LIBS)
+
+ if WITH_HSPELL
+ provider_LTLIBRARIES += enchant_hspell.la
+diff -rupN --no-dereference enchant-2.2.8/tests/test.pwl.orig enchant-2.2.8-new/tests/test.pwl.orig
+--- enchant-2.2.8/tests/test.pwl.orig 2017-02-04 18:34:34.000000000 +0100
++++ enchant-2.2.8-new/tests/test.pwl.orig 1970-01-01 01:00:00.000000000 +0100
+@@ -1,2 +0,0 @@
+-hello
+-tag