summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.json20
-rw-r--r--composer.spec41
-rw-r--r--installed.json261
4 files changed, 165 insertions, 159 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index a6f955b..2cb48d7 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.7")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.8")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.json b/composer.json
index c1e5286..7ca64f0 100644
--- a/composer.json
+++ b/composer.json
@@ -23,30 +23,30 @@
],
"require": {
"php": "^7.2.5 || ^8.0",
- "composer/ca-bundle": "^1.0",
+ "composer/ca-bundle": "^1.5",
"composer/class-map-generator": "^1.3.3",
"composer/metadata-minifier": "^1.0",
"composer/semver": "^3.3",
"composer/spdx-licenses": "^1.5.7",
"composer/xdebug-handler": "^2.0.2 || ^3.0.3",
- "justinrainbow/json-schema": "^5.2.11",
+ "justinrainbow/json-schema": "^5.3",
"psr/log": "^1.0 || ^2.0 || ^3.0",
"seld/jsonlint": "^1.4",
"seld/phar-utils": "^1.2",
- "symfony/console": "^5.4.11 || ^6.0.11 || ^7",
- "symfony/filesystem": "^5.4 || ^6.0 || ^7",
- "symfony/finder": "^5.4 || ^6.0 || ^7",
- "symfony/process": "^5.4 || ^6.0 || ^7",
- "react/promise": "^2.8 || ^3",
- "composer/pcre": "^2.1 || ^3.1",
+ "symfony/console": "^5.4.35 || ^6.3.12 || ^7.0.3",
+ "symfony/filesystem": "^5.4.35 || ^6.3.12 || ^7.0.3",
+ "symfony/finder": "^5.4.35 || ^6.3.12 || ^7.0.3",
+ "symfony/process": "^5.4.35 || ^6.3.12 || ^7.0.3",
+ "react/promise": "^3.2",
+ "composer/pcre": "^2.2 || ^3.2",
"symfony/polyfill-php73": "^1.24",
"symfony/polyfill-php80": "^1.24",
"symfony/polyfill-php81": "^1.24",
"seld/signal-handler": "^2.0"
},
"require-dev": {
- "symfony/phpunit-bridge": "^6.4.1 || ^7.0.1",
- "phpstan/phpstan": "^1.11.0",
+ "symfony/phpunit-bridge": "^6.4.3 || ^7.0.1",
+ "phpstan/phpstan": "^1.11.8",
"phpstan/phpstan-phpunit": "^1.4.0",
"phpstan/phpstan-deprecation-rules": "^1.2.0",
"phpstan/phpstan-strict-rules": "^1.6.0",
diff --git a/composer.spec b/composer.spec
index eb73880..5bef1d7 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 291942978f39435cf904d33739f98d7d4eca7b23
+%global gh_commit a2edd4e4414c17008ab585e0c62574fdb644ebfc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.7.7
+%global upstream_version 2.7.8
#global upstream_prever RC1
#global upstream_lower rc1
@@ -80,34 +80,34 @@ Requires: php-cli
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.5.0
-Provides: bundled(php-composer-class-map-generator) = 1.3.3
+Provides: bundled(php-composer-ca-bundle) = 1.5.1
+Provides: bundled(php-composer-class-map-generator) = 1.3.4
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 2.1.3
-Provides: bundled(php-composer-semver) = 3.4.0
+Provides: bundled(php-composer-pcre) = 2.3.0
+Provides: bundled(php-composer-semver) = 3.4.2
Provides: bundled(php-composer-spdx-licenses) = 1.5.8
Provides: bundled(php-composer-xdebug-handler) = 3.0.5
-Provides: bundled(php-justinrainbow-json-schema) = v5.2.13
+Provides: bundled(php-justinrainbow-json-schema) = 5.3.0
Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v3.2.0
-Provides: bundled(php-seld-jsonlint) = 1.10.2
+Provides: bundled(php-seld-jsonlint) = 1.11.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.2
-Provides: bundled(php-symfony-console) = v5.4.40
+Provides: bundled(php-symfony-console) = v5.4.42
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.3
-Provides: bundled(php-symfony-filesystem) = v5.4.40
-Provides: bundled(php-symfony-finder) = v5.4.40
-Provides: bundled(php-symfony-polyfill-ctype) = v1.29.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.29.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.29.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.29.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.29.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.29.0
+Provides: bundled(php-symfony-filesystem) = v5.4.41
+Provides: bundled(php-symfony-finder) = v5.4.42
+Provides: bundled(php-symfony-polyfill-ctype) = v1.30.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.30.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.30.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.30.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.30.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.30.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.30.0
Provides: bundled(php-symfony-process) = v5.4.40
Provides: bundled(php-symfony-service-contracts) = v2.5.3
-Provides: bundled(php-symfony-string) = v5.4.40
+Provides: bundled(php-symfony-string) = v5.4.42
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -249,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Fri Aug 23 2024 Remi Collet <remi@remirepo.net> - 2.7.8-1
+- update to 2.7.8
+
* Tue Jun 11 2024 Remi Collet <remi@remirepo.net> - 2.7.7-1
- update to 2.7.7
diff --git a/installed.json b/installed.json
index 2a78a33..7188267 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.5.0",
- "version_normalized": "1.5.0.0",
+ "version": "1.5.1",
+ "version_normalized": "1.5.1.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "0c5ccfcfea312b5c5a190a21ac5cef93f74baf99"
+ "reference": "063d9aa8696582f5a41dffbbaf3c81024f0a604a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/0c5ccfcfea312b5c5a190a21ac5cef93f74baf99",
- "reference": "0c5ccfcfea312b5c5a190a21ac5cef93f74baf99",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/063d9aa8696582f5a41dffbbaf3c81024f0a604a",
+ "reference": "063d9aa8696582f5a41dffbbaf3c81024f0a604a",
"shasum": ""
},
"require": {
@@ -22,11 +22,11 @@
},
"require-dev": {
"phpstan/phpstan": "^1.10",
- "psr/log": "^1.0",
+ "psr/log": "^1.0 || ^2.0 || ^3.0",
"symfony/phpunit-bridge": "^4.2 || ^5",
"symfony/process": "^4.0 || ^5.0 || ^6.0 || ^7.0"
},
- "time": "2024-03-15T14:00:32+00:00",
+ "time": "2024-07-08T15:28:20+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.5.0"
+ "source": "https://github.com/composer/ca-bundle/tree/1.5.1"
},
"funding": [
{
@@ -81,17 +81,17 @@
},
{
"name": "composer/class-map-generator",
- "version": "1.3.3",
- "version_normalized": "1.3.3.0",
+ "version": "1.3.4",
+ "version_normalized": "1.3.4.0",
"source": {
"type": "git",
"url": "https://github.com/composer/class-map-generator.git",
- "reference": "61804f9973685ec7bead0fb7fe022825e3cd418e"
+ "reference": "b1b3fd0b4eaf3ddf3ee230bc340bf3fff454a1a3"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/class-map-generator/zipball/61804f9973685ec7bead0fb7fe022825e3cd418e",
- "reference": "61804f9973685ec7bead0fb7fe022825e3cd418e",
+ "url": "https://api.github.com/repos/composer/class-map-generator/zipball/b1b3fd0b4eaf3ddf3ee230bc340bf3fff454a1a3",
+ "reference": "b1b3fd0b4eaf3ddf3ee230bc340bf3fff454a1a3",
"shasum": ""
},
"require": {
@@ -107,7 +107,7 @@
"symfony/filesystem": "^5.4 || ^6",
"symfony/phpunit-bridge": "^5"
},
- "time": "2024-06-10T11:53:54+00:00",
+ "time": "2024-06-12T14:13:04+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -137,7 +137,7 @@
],
"support": {
"issues": "https://github.com/composer/class-map-generator/issues",
- "source": "https://github.com/composer/class-map-generator/tree/1.3.3"
+ "source": "https://github.com/composer/class-map-generator/tree/1.3.4"
},
"funding": [
{
@@ -229,32 +229,40 @@
},
{
"name": "composer/pcre",
- "version": "2.1.3",
- "version_normalized": "2.1.3.0",
+ "version": "2.3.0",
+ "version_normalized": "2.3.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "540af382c97b83c628227d5f87cf56466d476191"
+ "reference": "06d0e49d6e136e4521c6bad18598bf0f6062ae37"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/540af382c97b83c628227d5f87cf56466d476191",
- "reference": "540af382c97b83c628227d5f87cf56466d476191",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/06d0e49d6e136e4521c6bad18598bf0f6062ae37",
+ "reference": "06d0e49d6e136e4521c6bad18598bf0f6062ae37",
"shasum": ""
},
"require": {
"php": "^7.2 || ^8.0"
},
+ "conflict": {
+ "phpstan/phpstan": "<1.11.10"
+ },
"require-dev": {
- "phpstan/phpstan": "^1.3",
+ "phpstan/phpstan": "^1.11.10",
"phpstan/phpstan-strict-rules": "^1.1",
- "symfony/phpunit-bridge": "^5"
+ "phpunit/phpunit": "^8 || ^9"
},
- "time": "2024-03-19T09:03:05+00:00",
+ "time": "2024-08-19T19:14:31+00:00",
"type": "library",
"extra": {
"branch-alias": {
"dev-main": "2.x-dev"
+ },
+ "phpstan": {
+ "includes": [
+ "extension.neon"
+ ]
}
},
"installation-source": "dist",
@@ -283,7 +291,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/2.1.3"
+ "source": "https://github.com/composer/pcre/tree/2.3.0"
},
"funding": [
{
@@ -303,17 +311,17 @@
},
{
"name": "composer/semver",
- "version": "3.4.0",
- "version_normalized": "3.4.0.0",
+ "version": "3.4.2",
+ "version_normalized": "3.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "35e8d0af4486141bc745f23a29cc2091eb624a32"
+ "reference": "c51258e759afdb17f1fd1fe83bc12baaef6309d6"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/35e8d0af4486141bc745f23a29cc2091eb624a32",
- "reference": "35e8d0af4486141bc745f23a29cc2091eb624a32",
+ "url": "https://api.github.com/repos/composer/semver/zipball/c51258e759afdb17f1fd1fe83bc12baaef6309d6",
+ "reference": "c51258e759afdb17f1fd1fe83bc12baaef6309d6",
"shasum": ""
},
"require": {
@@ -323,7 +331,7 @@
"phpstan/phpstan": "^1.4",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2023-08-31T09:50:34+00:00",
+ "time": "2024-07-12T11:35:52+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -367,7 +375,7 @@
"support": {
"irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.4.0"
+ "source": "https://github.com/composer/semver/tree/3.4.2"
},
"funding": [
{
@@ -539,37 +547,32 @@
},
{
"name": "justinrainbow/json-schema",
- "version": "v5.2.13",
- "version_normalized": "5.2.13.0",
+ "version": "5.3.0",
+ "version_normalized": "5.3.0.0",
"source": {
"type": "git",
"url": "https://github.com/jsonrainbow/json-schema.git",
- "reference": "fbbe7e5d79f618997bc3332a6f49246036c45793"
+ "reference": "feb2ca6dd1cebdaf1ed60a4c8de2e53ce11c4fd8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/jsonrainbow/json-schema/zipball/fbbe7e5d79f618997bc3332a6f49246036c45793",
- "reference": "fbbe7e5d79f618997bc3332a6f49246036c45793",
+ "url": "https://api.github.com/repos/jsonrainbow/json-schema/zipball/feb2ca6dd1cebdaf1ed60a4c8de2e53ce11c4fd8",
+ "reference": "feb2ca6dd1cebdaf1ed60a4c8de2e53ce11c4fd8",
"shasum": ""
},
"require": {
- "php": ">=5.3.3"
+ "php": ">=7.1"
},
"require-dev": {
"friendsofphp/php-cs-fixer": "~2.2.20||~2.15.1",
"json-schema/json-schema-test-suite": "1.2.0",
"phpunit/phpunit": "^4.8.35"
},
- "time": "2023-09-26T02:20:38+00:00",
+ "time": "2024-07-06T21:00:26+00:00",
"bin": [
"bin/validate-json"
],
"type": "library",
- "extra": {
- "branch-alias": {
- "dev-master": "5.0.x-dev"
- }
- },
"installation-source": "dist",
"autoload": {
"psr-4": {
@@ -606,7 +609,7 @@
],
"support": {
"issues": "https://github.com/jsonrainbow/json-schema/issues",
- "source": "https://github.com/jsonrainbow/json-schema/tree/v5.2.13"
+ "source": "https://github.com/jsonrainbow/json-schema/tree/5.3.0"
},
"install-path": "../justinrainbow/json-schema"
},
@@ -792,27 +795,27 @@
},
{
"name": "seld/jsonlint",
- "version": "1.10.2",
- "version_normalized": "1.10.2.0",
+ "version": "1.11.0",
+ "version_normalized": "1.11.0.0",
"source": {
"type": "git",
"url": "https://github.com/Seldaek/jsonlint.git",
- "reference": "9bb7db07b5d66d90f6ebf542f09fc67d800e5259"
+ "reference": "1748aaf847fc731cfad7725aec413ee46f0cc3a2"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/Seldaek/jsonlint/zipball/9bb7db07b5d66d90f6ebf542f09fc67d800e5259",
- "reference": "9bb7db07b5d66d90f6ebf542f09fc67d800e5259",
+ "url": "https://api.github.com/repos/Seldaek/jsonlint/zipball/1748aaf847fc731cfad7725aec413ee46f0cc3a2",
+ "reference": "1748aaf847fc731cfad7725aec413ee46f0cc3a2",
"shasum": ""
},
"require": {
"php": "^5.3 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpstan/phpstan": "^1.5",
+ "phpstan/phpstan": "^1.11",
"phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0 || ^8.5.13"
},
- "time": "2024-02-07T12:57:50+00:00",
+ "time": "2024-07-11T14:55:45+00:00",
"bin": [
"bin/jsonlint"
],
@@ -843,7 +846,7 @@
],
"support": {
"issues": "https://github.com/Seldaek/jsonlint/issues",
- "source": "https://github.com/Seldaek/jsonlint/tree/1.10.2"
+ "source": "https://github.com/Seldaek/jsonlint/tree/1.11.0"
},
"funding": [
{
@@ -974,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.40",
- "version_normalized": "5.4.40.0",
+ "version": "v5.4.42",
+ "version_normalized": "5.4.42.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "aa73115c0c24220b523625bfcfa655d7d73662dd"
+ "reference": "cef62396a0477e94fc52e87a17c6e5c32e226b7f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/aa73115c0c24220b523625bfcfa655d7d73662dd",
- "reference": "aa73115c0c24220b523625bfcfa655d7d73662dd",
+ "url": "https://api.github.com/repos/symfony/console/zipball/cef62396a0477e94fc52e87a17c6e5c32e226b7f",
+ "reference": "cef62396a0477e94fc52e87a17c6e5c32e226b7f",
"shasum": ""
},
"require": {
@@ -1022,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2024-05-31T14:33:22+00:00",
+ "time": "2024-07-26T12:21:55+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1056,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.40"
+ "source": "https://github.com/symfony/console/tree/v5.4.42"
},
"funding": [
{
@@ -1146,17 +1149,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.40",
- "version_normalized": "5.4.40.0",
+ "version": "v5.4.41",
+ "version_normalized": "5.4.41.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "26dd9912df6940810ea00f8f53ad48d6a3424995"
+ "reference": "6d29dd9340b372fa603f04e6df4dd76bb808591e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/26dd9912df6940810ea00f8f53ad48d6a3424995",
- "reference": "26dd9912df6940810ea00f8f53ad48d6a3424995",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/6d29dd9340b372fa603f04e6df4dd76bb808591e",
+ "reference": "6d29dd9340b372fa603f04e6df4dd76bb808591e",
"shasum": ""
},
"require": {
@@ -1168,7 +1171,7 @@
"require-dev": {
"symfony/process": "^5.4|^6.4"
},
- "time": "2024-05-31T14:33:22+00:00",
+ "time": "2024-06-28T09:36:24+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1196,7 +1199,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.40"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.41"
},
"funding": [
{
@@ -1216,17 +1219,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.40",
- "version_normalized": "5.4.40.0",
+ "version": "v5.4.42",
+ "version_normalized": "5.4.42.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "f51cff4687547641c7d8180d74932ab40b2205ce"
+ "reference": "0724c51fa067b198e36506d2864e09a52180998a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/f51cff4687547641c7d8180d74932ab40b2205ce",
- "reference": "f51cff4687547641c7d8180d74932ab40b2205ce",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/0724c51fa067b198e36506d2864e09a52180998a",
+ "reference": "0724c51fa067b198e36506d2864e09a52180998a",
"shasum": ""
},
"require": {
@@ -1234,7 +1237,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-05-31T14:33:22+00:00",
+ "time": "2024-07-22T08:53:29+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1262,7 +1265,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.40"
+ "source": "https://github.com/symfony/finder/tree/v5.4.42"
},
"funding": [
{
@@ -1282,17 +1285,17 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "ef4d7e442ca910c4764bce785146269b30cb5fc4"
+ "reference": "0424dff1c58f028c451efff2045f5d92410bd540"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/ef4d7e442ca910c4764bce785146269b30cb5fc4",
- "reference": "ef4d7e442ca910c4764bce785146269b30cb5fc4",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/0424dff1c58f028c451efff2045f5d92410bd540",
+ "reference": "0424dff1c58f028c451efff2045f5d92410bd540",
"shasum": ""
},
"require": {
@@ -1304,7 +1307,7 @@
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1344,7 +1347,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.30.0"
},
"funding": [
{
@@ -1364,17 +1367,17 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "32a9da87d7b3245e09ac426c83d334ae9f06f80f"
+ "reference": "64647a7c30b2283f5d49b874d84a18fc22054b7a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/32a9da87d7b3245e09ac426c83d334ae9f06f80f",
- "reference": "32a9da87d7b3245e09ac426c83d334ae9f06f80f",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/64647a7c30b2283f5d49b874d84a18fc22054b7a",
+ "reference": "64647a7c30b2283f5d49b874d84a18fc22054b7a",
"shasum": ""
},
"require": {
@@ -1383,7 +1386,7 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1425,7 +1428,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.30.0"
},
"funding": [
{
@@ -1445,17 +1448,17 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
- "reference": "bc45c394692b948b4d383a08d7753968bed9a83d"
+ "reference": "a95281b0be0d9ab48050ebd988b967875cdb9fdb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/bc45c394692b948b4d383a08d7753968bed9a83d",
- "reference": "bc45c394692b948b4d383a08d7753968bed9a83d",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/a95281b0be0d9ab48050ebd988b967875cdb9fdb",
+ "reference": "a95281b0be0d9ab48050ebd988b967875cdb9fdb",
"shasum": ""
},
"require": {
@@ -1464,7 +1467,7 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1509,7 +1512,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.30.0"
},
"funding": [
{
@@ -1529,17 +1532,17 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "9773676c8a1bb1f8d4340a62efe641cf76eda7ec"
+ "reference": "fd22ab50000ef01661e2a31d850ebaa297f8e03c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/9773676c8a1bb1f8d4340a62efe641cf76eda7ec",
- "reference": "9773676c8a1bb1f8d4340a62efe641cf76eda7ec",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/fd22ab50000ef01661e2a31d850ebaa297f8e03c",
+ "reference": "fd22ab50000ef01661e2a31d850ebaa297f8e03c",
"shasum": ""
},
"require": {
@@ -1551,7 +1554,7 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-06-19T12:30:46+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1592,7 +1595,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.30.0"
},
"funding": [
{
@@ -1612,23 +1615,23 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
- "reference": "21bd091060673a1177ae842c0ef8fe30893114d2"
+ "reference": "ec444d3f3f6505bb28d11afa41e75faadebc10a1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/21bd091060673a1177ae842c0ef8fe30893114d2",
- "reference": "21bd091060673a1177ae842c0ef8fe30893114d2",
+ "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/ec444d3f3f6505bb28d11afa41e75faadebc10a1",
+ "reference": "ec444d3f3f6505bb28d11afa41e75faadebc10a1",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1671,7 +1674,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.30.0"
},
"funding": [
{
@@ -1691,23 +1694,23 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "87b68208d5c1188808dd7839ee1e6c8ec3b02f1b"
+ "reference": "77fa7995ac1b21ab60769b7323d600a991a90433"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/87b68208d5c1188808dd7839ee1e6c8ec3b02f1b",
- "reference": "87b68208d5c1188808dd7839ee1e6c8ec3b02f1b",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/77fa7995ac1b21ab60769b7323d600a991a90433",
+ "reference": "77fa7995ac1b21ab60769b7323d600a991a90433",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1754,7 +1757,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.30.0"
},
"funding": [
{
@@ -1774,23 +1777,23 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
- "reference": "c565ad1e63f30e7477fc40738343c62b40bc672d"
+ "reference": "3fb075789fb91f9ad9af537c4012d523085bd5af"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/c565ad1e63f30e7477fc40738343c62b40bc672d",
- "reference": "c565ad1e63f30e7477fc40738343c62b40bc672d",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/3fb075789fb91f9ad9af537c4012d523085bd5af",
+ "reference": "3fb075789fb91f9ad9af537c4012d523085bd5af",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-06-19T12:30:46+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1833,7 +1836,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.30.0"
},
"funding": [
{
@@ -2004,17 +2007,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.40",
- "version_normalized": "5.4.40.0",
+ "version": "v5.4.42",
+ "version_normalized": "5.4.42.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "142877285aa974a6f7685e292ab5ba9aae86b143"
+ "reference": "909cec913edea162a3b2836788228ad45fcab337"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/142877285aa974a6f7685e292ab5ba9aae86b143",
- "reference": "142877285aa974a6f7685e292ab5ba9aae86b143",
+ "url": "https://api.github.com/repos/symfony/string/zipball/909cec913edea162a3b2836788228ad45fcab337",
+ "reference": "909cec913edea162a3b2836788228ad45fcab337",
"shasum": ""
},
"require": {
@@ -2034,7 +2037,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2024-05-31T14:33:22+00:00",
+ "time": "2024-07-20T18:38:32+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2073,7 +2076,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.40"
+ "source": "https://github.com/symfony/string/tree/v5.4.42"
},
"funding": [
{