summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion4
-rw-r--r--composer.spec16
-rw-r--r--installed.json56
3 files changed, 39 insertions, 37 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 2cb48d7..1397e05 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -7,7 +7,7 @@
_sf_composer() {
# Use newline as only separator to allow space in completion values
- IFS=$'\n'
+ local IFS=$'\n'
local sf_cmd="${COMP_WORDS[0]}"
# for an alias, get the real script behind it
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.8")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.9")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 5bef1d7..474c371 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit a2edd4e4414c17008ab585e0c62574fdb644ebfc
+%global gh_commit e30ccdd665828ae66eb1be78f056e39e1d5f55ab
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.7.8
+%global upstream_version 2.7.9
#global upstream_prever RC1
#global upstream_lower rc1
@@ -83,7 +83,7 @@ Requires: ca-certificates
Provides: bundled(php-composer-ca-bundle) = 1.5.1
Provides: bundled(php-composer-class-map-generator) = 1.3.4
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 2.3.0
+Provides: bundled(php-composer-pcre) = 2.3.1
Provides: bundled(php-composer-semver) = 3.4.2
Provides: bundled(php-composer-spdx-licenses) = 1.5.8
Provides: bundled(php-composer-xdebug-handler) = 3.0.5
@@ -94,10 +94,10 @@ Provides: bundled(php-react-promise) = v3.2.0
Provides: bundled(php-seld-jsonlint) = 1.11.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.2
-Provides: bundled(php-symfony-console) = v5.4.42
+Provides: bundled(php-symfony-console) = v5.4.43
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.3
Provides: bundled(php-symfony-filesystem) = v5.4.41
-Provides: bundled(php-symfony-finder) = v5.4.42
+Provides: bundled(php-symfony-finder) = v5.4.43
Provides: bundled(php-symfony-polyfill-ctype) = v1.30.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.30.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.30.0
@@ -107,7 +107,7 @@ Provides: bundled(php-symfony-polyfill-php80) = v1.30.0
Provides: bundled(php-symfony-polyfill-php81) = v1.30.0
Provides: bundled(php-symfony-process) = v5.4.40
Provides: bundled(php-symfony-service-contracts) = v2.5.3
-Provides: bundled(php-symfony-string) = v5.4.42
+Provides: bundled(php-symfony-string) = v5.4.43
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -237,7 +237,6 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md doc
%doc composer.json
@@ -249,6 +248,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Wed Sep 4 2024 Remi Collet <remi@remirepo.net> - 2.7.9-1
+- update to 2.7.9
+
* Fri Aug 23 2024 Remi Collet <remi@remirepo.net> - 2.7.8-1
- update to 2.7.8
diff --git a/installed.json b/installed.json
index 7188267..5806978 100644
--- a/installed.json
+++ b/installed.json
@@ -229,17 +229,17 @@
},
{
"name": "composer/pcre",
- "version": "2.3.0",
- "version_normalized": "2.3.0.0",
+ "version": "2.3.1",
+ "version_normalized": "2.3.1.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "06d0e49d6e136e4521c6bad18598bf0f6062ae37"
+ "reference": "26859a860a7f140fc08422c3cc14ad9c2a287d79"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/06d0e49d6e136e4521c6bad18598bf0f6062ae37",
- "reference": "06d0e49d6e136e4521c6bad18598bf0f6062ae37",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/26859a860a7f140fc08422c3cc14ad9c2a287d79",
+ "reference": "26859a860a7f140fc08422c3cc14ad9c2a287d79",
"shasum": ""
},
"require": {
@@ -253,7 +253,7 @@
"phpstan/phpstan-strict-rules": "^1.1",
"phpunit/phpunit": "^8 || ^9"
},
- "time": "2024-08-19T19:14:31+00:00",
+ "time": "2024-08-27T12:02:26+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -291,7 +291,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/2.3.0"
+ "source": "https://github.com/composer/pcre/tree/2.3.1"
},
"funding": [
{
@@ -977,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.42",
- "version_normalized": "5.4.42.0",
+ "version": "v5.4.43",
+ "version_normalized": "5.4.43.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "cef62396a0477e94fc52e87a17c6e5c32e226b7f"
+ "reference": "e86f8554de667c16dde8aeb89a3990cfde924df9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/cef62396a0477e94fc52e87a17c6e5c32e226b7f",
- "reference": "cef62396a0477e94fc52e87a17c6e5c32e226b7f",
+ "url": "https://api.github.com/repos/symfony/console/zipball/e86f8554de667c16dde8aeb89a3990cfde924df9",
+ "reference": "e86f8554de667c16dde8aeb89a3990cfde924df9",
"shasum": ""
},
"require": {
@@ -1025,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2024-07-26T12:21:55+00:00",
+ "time": "2024-08-13T16:31:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1059,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.42"
+ "source": "https://github.com/symfony/console/tree/v5.4.43"
},
"funding": [
{
@@ -1219,17 +1219,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.42",
- "version_normalized": "5.4.42.0",
+ "version": "v5.4.43",
+ "version_normalized": "5.4.43.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "0724c51fa067b198e36506d2864e09a52180998a"
+ "reference": "ae25a9145a900764158d439653d5630191155ca0"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/0724c51fa067b198e36506d2864e09a52180998a",
- "reference": "0724c51fa067b198e36506d2864e09a52180998a",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/ae25a9145a900764158d439653d5630191155ca0",
+ "reference": "ae25a9145a900764158d439653d5630191155ca0",
"shasum": ""
},
"require": {
@@ -1237,7 +1237,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-07-22T08:53:29+00:00",
+ "time": "2024-08-13T14:03:51+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1265,7 +1265,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.42"
+ "source": "https://github.com/symfony/finder/tree/v5.4.43"
},
"funding": [
{
@@ -2007,17 +2007,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.42",
- "version_normalized": "5.4.42.0",
+ "version": "v5.4.43",
+ "version_normalized": "5.4.43.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "909cec913edea162a3b2836788228ad45fcab337"
+ "reference": "8be1d484951ff5ca995eaf8edcbcb8b9a5888450"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/909cec913edea162a3b2836788228ad45fcab337",
- "reference": "909cec913edea162a3b2836788228ad45fcab337",
+ "url": "https://api.github.com/repos/symfony/string/zipball/8be1d484951ff5ca995eaf8edcbcb8b9a5888450",
+ "reference": "8be1d484951ff5ca995eaf8edcbcb8b9a5888450",
"shasum": ""
},
"require": {
@@ -2037,7 +2037,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2024-07-20T18:38:32+00:00",
+ "time": "2024-08-01T10:24:28+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2076,7 +2076,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.42"
+ "source": "https://github.com/symfony/string/tree/v5.4.43"
},
"funding": [
{